Bug 5991 - Javascript error on purchase suggestion pages
Summary: Javascript error on purchase suggestion pages
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-29 18:22 UTC by Owen Leonard
Modified: 2012-10-25 23:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (2.98 KB, patch)
2011-03-29 18:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Revised fix (3.21 KB, patch)
2011-04-04 12:50 UTC, Owen Leonard
Details | Diff | Splinter Review
Signed off patch (3.27 KB, patch)
2011-04-04 14:13 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-03-29 18:22:04 UTC
1. On the main suggestions page there is a javascript error caused by a function running which applies only to the edit page.
2. On the edit page, the following error occurs:

listprice is not defined /intranet-tmpl/prog/en/js/acq.js Line 698

There is no "listprice" form field, so I'm assuming it should be "price."
Comment 1 Owen Leonard 2011-03-29 18:45:12 UTC Comment hidden (obsolete)
Comment 2 Paul Poulain 2011-04-04 12:31:16 UTC
unless i'm missing something, a recent change makes the patch not apply anymore
Comment 3 Owen Leonard 2011-04-04 12:50:37 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2011-04-04 14:13:01 UTC
Created attachment 3631 [details] [review]
Signed off patch
Comment 5 Chris Cormack 2011-04-04 22:15:10 UTC
Pushed, please test