Bug 6162 - name missing on reading history in opac
Summary: name missing on reading history in opac
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Colin Campbell
QA Contact: Bugs List
URL: cgi-bin/koha/opac-readingrecord.pl
Keywords:
Depends on:
Blocks: 5917
  Show dependency treegraph
 
Reported: 2011-04-11 16:13 UTC by Nicole C. Engard
Modified: 2012-10-25 23:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
missing name (92.88 KB, image/png)
2011-04-11 16:13 UTC, Nicole C. Engard
Details
Proposed fix (1.37 KB, patch)
2011-04-11 18:35 UTC, Owen Leonard
Details | Diff | Splinter Review
Proposed patch (2.76 KB, patch)
2011-04-12 10:50 UTC, Colin Campbell
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-04-11 16:13:54 UTC
Created attachment 3869 [details]
missing name

on my reading history in the opac my name isn't showing ... it shows on other tabs in the opac and at the top right, just not on this tab.

I'm on Mac and FF4
Comment 1 Owen Leonard 2011-04-11 18:35:10 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2011-04-11 21:34:34 UTC
Pushed, please test
Comment 3 Colin Campbell 2011-04-12 10:36:11 UTC
The template is correct there is not (or rather should not be) an array of names. The problem is in the perl script which sends the borrower details twice both times incorrectly. Will send patch fixing script & template
Comment 4 Colin Campbell 2011-04-12 10:50:45 UTC
Created attachment 3889 [details] [review]
Proposed patch

Patch to fix the confused passing of borrower details to the template. Fix that and we don't need to complicate the template by referring to arrays which arn't, removes the loop code from the template
Comment 5 Chris Cormack 2011-04-14 03:03:09 UTC
Follow up patch from Colin pushed, please test