Bug 6173 - Cronjob to send account expiry notices
Summary: Cronjob to send account expiry notices
Status: RESOLVED DUPLICATE of bug 6810
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 13:46 UTC by Koustubha Kale
Modified: 2014-11-02 10:53 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
cronjob file (7.31 KB, application/x-perl)
2011-04-12 13:46 UTC, Koustubha Kale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Koustubha Kale 2011-04-12 13:46:09 UTC
Created attachment 3897 [details]
cronjob file

This is a cronjob hacked from advanced_notices.pl to send out emails to patrons nearing account expiry.
The notice template code is hardcoded to EXP so make sure you modify only that notice template. and it can handle  borrowers.borrowernumber, borrowers.title, borrowers.firstname, borrowers.surname, borrowers.dateexpiry fields in the notice.
The number of days to expiry can be set with a command line switch -m
The script puts the emails in Koha's default message queue so its system compatible.

It can be improved in a number of ways like for create syspref for sending these reminders, and setting the days in advance.

I can submit a patch if this is useful..
Comment 1 Katrin Fischer 2014-11-02 10:53:47 UTC
Marking this duplicate of bug 6810 as this has been worked on more recently.

*** This bug has been marked as a duplicate of bug 6810 ***