Bug 6179 - Extra column on fines in staff client
Summary: Extra column on fines in staff client
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5917
  Show dependency treegraph
 
Reported: 2011-04-13 15:41 UTC by Nicole C. Engard
Modified: 2012-10-25 23:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
fines in staff client (64.99 KB, image/png)
2011-04-13 15:41 UTC, Nicole C. Engard
Details
Proposed fix (1.98 KB, patch)
2011-04-13 15:55 UTC, Owen Leonard
Details | Diff | Splinter Review
table now (57.63 KB, image/png)
2011-04-20 01:02 UTC, Nicole C. Engard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-04-13 15:41:24 UTC
Created attachment 3909 [details]
fines in staff client

On the staff client when viewing fines there is an extra row that is causing things to not line up properly.
Comment 1 Owen Leonard 2011-04-13 15:55:07 UTC
Created attachment 3910 [details] [review]
Proposed fix

Fixing a template variable scope error fixes the column error. This patch also includes a fix for the column span error in the table footer.
Comment 2 Chris Cormack 2011-04-14 03:06:54 UTC
Pushed, please test
Comment 3 Nicole C. Engard 2011-04-20 01:02:30 UTC
Created attachment 3953 [details]
table now

The extra column is gone after the patch - but I'm going to be nit picky and say that there is a white square at the bottom of the print column that should probably be grey like the rest of the row :)
Comment 4 Owen Leonard 2011-04-20 13:19:27 UTC
> but I'm going to be nit picky and
> say that there is a white square at the bottom of the print column that should
> probably be grey like the rest of the row :)

I'll see your nit picky and raise you multiple lines of template logic in my patch which should have eliminated that white square. Seriously though, I can't reproduce this. If you can figure out how to make this happen I'll take another look.
Comment 5 Nicole C. Engard 2011-04-20 14:56:27 UTC
once again it's a FF4 thing ... apparently FF4 has all kinds of issues :(
Comment 6 Magnus Enger 2011-05-16 09:35:19 UTC
The table is properly aligned in current master.