Bug 6293 - Add a button to the intranet for registering with the Koha community
Summary: Add a button to the intranet for registering with the Koha community
Status: RESOLVED DUPLICATE of bug 11926
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 08:18 UTC by Magnus Enger
Modified: 2014-03-12 22:18 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2011-05-03 08:18:01 UTC
This came up on IRC today, slightly edited version of the conversation follows: 

<rangi> back in about 1.2 days
<1angi> as part of the makefile 
<rangi> we had an option to 'register'
<rangi> magnuse/paul_p: maybe a button in the about page, register with the koha community ?
<rangi> it could submit the about info, that way we could get info about versions too
<rangi> would just need a webservice listening that it could post too
<rangi> maybe on koha-community.org
<rangi> and totally voluntary
<snail> does the generated HTML advertise the version? we could check automagically for updates / statuses
<rangi> snail: yeah if they were out on the web, lots of special/corporate libraries live on intranets
<magnuse> it's in the generator meta tag
<magnuse> <meta name="generator" content="Koha 3.0500001" /> <!-- leave this for stats -->
<snail> dspace is switching to advertising versions in the generator tag too
<rangi> i think a button where we can encourage ppl to click on 
<rangi> is a good first step
<rangi> then we could extend it to periodically check
<rangi> maybe a checkbox
<rangi> some way to opt back out again
<rangi> ie to turn our checking off
<rangi> it could be a checkbox/syspref that just adds 'dont check' to the html, and then they have to resubmit
<rangi> we need a student, its a perfect little project for a student, build a db, an a script to populate it
<rangi> then add the button to koha
<rangi> you dont even need to know [K]oha to do it

The log: http://stats.workbuffer.org/irclog/koha/2011-05-03#i_658645
Comment 1 stuart yeates 2011-05-03 08:23:23 UTC
It would be even cooler if the line contained a URL into a repository. This would avoid confusion over which people had which features when they'd built their own koha version.

<meta name="generator" content="Koha 3.0500001 http://git.koha-community.org/gitweb/" />
Comment 3 stuart yeates 2011-05-03 09:46:26 UTC
If there was consensus about it, we could also add koha sites to netcraft (see for example http://toolbar.netcraft.com/site_report?url=www.library.org.nz ) and http://www.librarytechnology.org/libwebcats/
Comment 4 Magnus Enger 2014-03-12 22:18:51 UTC

*** This bug has been marked as a duplicate of bug 11926 ***