Bug 6323 - Attach/move items - adding option "try again" after success or wrong barcode
Summary: Attach/move items - adding option "try again" after success or wrong barcode
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.8
Hardware: All All
: P3 enhancement (vote)
Target Milestone: ---
Assignee: Liz Rea
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-09 14:26 UTC by Liz Rea
Modified: 2013-12-05 20:01 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.97 KB, patch)
2011-05-09 15:45 UTC, Liz Rea
Details | Diff | Splinter Review
This patch replaces the other one (6.68 KB, patch)
2011-05-10 20:20 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (6.99 KB, patch)
2011-09-28 14:16 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (7.06 KB, patch)
2011-11-07 14:55 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (5.67 KB, patch)
2011-11-17 20:09 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (5.69 KB, patch)
2011-11-17 20:20 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (5.79 KB, patch)
2011-12-19 16:19 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (6.40 KB, patch)
2011-12-19 20:33 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (6.39 KB, patch)
2011-12-19 21:04 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (6.39 KB, patch)
2011-12-19 21:33 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (6.39 KB, patch)
2011-12-21 19:40 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6323 -- Error handling cleanup for moveitem.tt (6.40 KB, patch)
2011-12-22 19:45 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2011-05-09 14:26:55 UTC
When an item move fails, the current behavior is to send the user back to the MARC detail page only. I believe there should be an option to "try again with a different barcode."
Comment 1 Liz Rea 2011-05-09 15:45:34 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2011-05-10 20:20:57 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2011-05-10 20:24:07 UTC
Comment on attachment 4064 [details] [review]
Proposed patch

this patch is lesser than the other, please use it instead.
Comment 4 Paul Poulain 2011-08-10 16:01:16 UTC
QA comment

Sorry, but the patch doesn't apply anymore, and it seems it's not only a glitch I can fix while QAing. => does not apply
Comment 5 Liz Rea 2011-09-28 14:16:45 UTC Comment hidden (obsolete)
Comment 6 Owen Leonard 2011-10-06 20:08:15 UTC
I thought it was clearer when the button said "Try a different barcode."
Comment 7 Paul Poulain 2011-10-24 11:38:06 UTC
Updating Version : This ENH will be for Koha 3.8
Comment 8 Paul Poulain 2011-10-25 15:05:40 UTC
Bug versionned for master. entries will be made against rel_3_8 once the patch has been applied (see thread about that on koha-devel yesterday)
Comment 9 Liz Rea 2011-11-07 14:55:56 UTC Comment hidden (obsolete)
Comment 10 Liz Rea 2011-11-07 14:57:09 UTC
Comment on attachment 6249 [details] [review]
Bug 6323 -- Error handling cleanup for moveitem.tt

This latest patch changes the wording back to "try again with a different barcode"
Comment 11 Liz Rea 2011-11-17 20:09:37 UTC Comment hidden (obsolete)
Comment 12 Chris Cormack 2011-11-17 20:20:15 UTC Comment hidden (obsolete)
Comment 13 Marcel de Rooy 2011-12-19 08:29:41 UTC
QA Comment:
You use form method=link in the template. This is not an official method in html. It should be get or post. I tried to find another example in current Koha code/template, but it is not present. So I think we should not introduce it, although it probably works. Links should be <a> tags; you can customize layout with css.

The action block contains ending tags without opening tags. This may work since the opening tags could be before the include. But for maintenance, I would personally not favor it. It would be better if this block is correct on its own.
Comment 14 Liz Rea 2011-12-19 16:19:27 UTC Comment hidden (obsolete)
Comment 15 Liz Rea 2011-12-19 20:33:26 UTC Comment hidden (obsolete)
Comment 16 Liz Rea 2011-12-19 21:04:37 UTC Comment hidden (obsolete)
Comment 17 Liz Rea 2011-12-19 21:33:52 UTC Comment hidden (obsolete)
Comment 18 Liz Rea 2011-12-21 19:40:55 UTC Comment hidden (obsolete)
Comment 19 Chris Cormack 2011-12-22 19:45:59 UTC
Created attachment 6927 [details] [review]
Bug 6323 -- Error handling cleanup for moveitem.tt

Added button to retry attaching item, added default bib view handling, cosmetic changes to the error display (buttons now in error div).

Incorporates changes that should satisfy QA.

To test:
Find a bib with multiple items and grab one of the barcodes.
Go to a second bib and click Edit -> Attach item
Paste your barcode in there and click "Submit"
Click the "Try again with a different barcode" button. It should take you back to the barcode entry screen.

Also try with a non-existent barcode and verify that the button appears and works as intended.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 20 Marcel de Rooy 2012-01-26 08:01:40 UTC
QA Comment: Changed to satisfy earlier comments. Thanks. Looks good. Updating status..