Bug 6398 - Holidays cause date due to be improperly calculated
Summary: Holidays cause date due to be improperly calculated
Status: RESOLVED DUPLICATE of bug 8418
Alias: None
Product: Koha
Classification: Unclassified
Component: Holidays (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Dobrica Pavlinusic
QA Contact: Bugs List
URL:
Keywords:
Depends on: 8418
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-24 14:43 UTC by Owen Leonard
Modified: 2012-09-20 17:36 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-05-24 14:43:09 UTC
- Checking out items on 24 May.
- Loan period is set to 14 days.
- useDaysMode is set to "Calculate the due date using the calendar
  to push the due date to the next open day."   
- Holiday set for 30 May.
- Items are checked out with date due 8 June: 15 days.

When calculating the due date the loan period should be extended by one day *only* if the due date would otherwise fall on the holiday date. In this case the due date is getting pushed forward just because a holiday falls between now and the due date.
Comment 1 Dobrica Pavlinusic 2012-07-11 16:54:38 UTC
I found this bug after I opened

Bug 8418 - Koha::Calendar is_holiday ignores all user data

which is basically a duplicate of this one. Sorry about that :-)
Comment 2 Tomás Cohen Arazi 2012-09-20 17:36:20 UTC

*** This bug has been marked as a duplicate of bug 8418 ***