Bug 6413 - Notes in Fines doing wonky things
Summary: Notes in Fines doing wonky things
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.14
Hardware: All All
: P5 - low major (vote)
Assignee: Kyle M Hall
QA Contact: Paul Poulain
URL:
Whiteboard:
Keywords:
: 7004 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-26 19:00 UTC by Nicole C. Engard
Modified: 2014-12-07 20:02 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Added ability to add notes when paying or writing off fines (9.60 KB, patch)
2012-01-26 03:24 UTC, Chris Hall
Details | Diff | Splinter Review
Added ability to add notes when paying or writing off fines (10.29 KB, patch)
2012-02-08 01:17 UTC, Chris Hall
Details | Diff | Splinter Review
Added ability to add notes when paying or writing off fines (10.96 KB, patch)
2012-04-11 04:46 UTC, Chris Hall
Details | Diff | Splinter Review
Bug 6413 Added ability to add a note when paying or writing off a fine Code will also respect notes when using the "Writeoff All" button but WILL NOT when using either the "Pay Amount" or "Pay Selected" buttons Fixed uri encoding of arguments (10.94 KB, patch)
2012-04-11 21:10 UTC, Chris Cormack
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6413 Added ability to add a note when paying or writing off a fine (11.10 KB, patch)
2012-04-12 12:26 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Added ability to add notes when paying or writing off fines (10.97 KB, patch)
2012-04-16 20:58 UTC, Chris Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6413 Added ability to add a note when paying or writing off a fine (10.97 KB, patch)
2012-04-17 01:19 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 6413 follow-up: fixing capital case & tabs (1.13 KB, patch)
2012-04-30 16:13 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 6413 Added ability to add a note when paying or writing off a fine (11.24 KB, patch)
2012-10-03 13:12 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 Added ability to add a note when paying or writing off a fine (11.24 KB, patch)
2012-10-03 13:43 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 follow-up: fixing capital case & tabs (1.20 KB, patch)
2012-10-03 23:55 UTC, Mason James
Details | Diff | Splinter Review
Bug 6413 Added ability to add a note when paying or writing off a fine (11.34 KB, patch)
2012-10-03 23:55 UTC, Mason James
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6413 Added ability to add a note when paying or writing off a fine (11.30 KB, patch)
2013-01-24 19:02 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 - QA Followup (984 bytes, patch)
2013-01-24 19:04 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 follow-up: fixing capital case & tabs (1.13 KB, patch)
2013-01-24 19:07 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 - QA Followup - Add notes for 'Pay selected' (5.32 KB, patch)
2013-01-24 20:45 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 - QA Followup - Add notes for 'Pay selected' (5.12 KB, patch)
2013-01-25 12:43 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6413 follow-up: fixing capital case & tabs (1.18 KB, patch)
2013-01-28 14:46 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 - QA Followup - Add notes for 'Pay selected' (5.82 KB, patch)
2013-01-28 14:47 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 - QA Followup - Add notes for 'Pay selected' (6.25 KB, patch)
2013-01-28 16:56 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6413 - QA Followup - Add notes for 'Pay selected' (6.36 KB, patch)
2013-01-28 17:31 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 6413 Added ability to add a note when paying or writing off a fine (11.28 KB, patch)
2013-02-11 12:48 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 follow-up: fixing capital case & tabs (1.18 KB, patch)
2013-02-11 12:48 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6413 - QA Followup - Add notes for 'Pay selected' (6.30 KB, patch)
2013-02-11 12:49 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA]Bug 6413 Added ability to add a note when paying or writing off a fine (11.51 KB, patch)
2013-03-20 10:48 UTC, Paul Poulain
Details | Diff | Splinter Review
[PASSED QA]Bug 6413 Added ability to add a note when paying or writing off a fine (11.51 KB, patch)
2013-03-20 10:53 UTC, Paul Poulain
Details | Diff | Splinter Review
[PASSED QA]Bug 6413 follow-up: fixing capital case & tabs (1.27 KB, patch)
2013-03-20 10:53 UTC, Paul Poulain
Details | Diff | Splinter Review
[PASSED QA]Bug 6413 - QA Followup - Add notes for 'Pay selected' (6.59 KB, patch)
2013-03-20 10:53 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 6413 - QA Followup - Remove extra table column header (811 bytes, patch)
2013-05-08 16:42 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-05-26 19:00:55 UTC
Follow these steps:

Add a manual invoice with a note
Add a second manual invoice with a different note
Pay the first invoice using the 'pay' tab 
   the note carries over but is not published on the 'pay' line
Pay the second invoice and put a different note in 
   the note isn't put on the payment line, but the note on the charge is changed


Logically, there should be a note for the payment line and a note for the charge line, they don't have to be the same. As it is now you can't add a note on a payment line at all, but the field is there.
Comment 1 Nicole C. Engard 2011-05-26 19:10:22 UTC
Example video: http://screencast.com/t/bPYEhgtAj
Comment 2 Chris Cormack 2011-09-05 01:34:52 UTC
Looking into this
Comment 3 Chris Cormack 2011-09-05 01:44:20 UTC
Its working as designed, it allows you to modify the note on the charge when you save.

It was never designed to add a new note on the payment line.

So changing it would be changing behaviour, which would make it impossible for libraries to change the note on a charge when the pay it off.

Is that desirable? 

I think it would have to be done in a way that allows current behaviour to still continue, but also allow someone to add a note on the payment line.
Comment 4 Nicole C. Engard 2011-09-07 16:56:18 UTC
I honestly don't know.  It sounds like if that's how it's supposed to be then maybe we shouldn't consider what I'm asking for a bug.  Instead this is a feature request to be able to add a note to payments that is separate from the fine line.  Anyone else have any opinions?  Maybe a way to make this clearer to the librarian what's going to happen because it looks like the note is going on the payment line because that's where the form is appearing.

Nicole
Comment 5 Chris Hall 2012-01-06 02:16:53 UTC
The ability to add a note when paying a fine appears to have been removed in the patch for bug 3498 Allow partial payments of fines (507c7f422485aaf7ae601b0a84bacdbaedac061c).

Is adding it back in desirable?
If so, is the ability to also edit the notes on fines still required? Currently it is not possible so not having it is not reverting, however it could be added in via an edit button on the fines page or something similar.
Comment 6 Nicole C. Engard 2012-01-06 13:47:44 UTC
I've had several libraries ask to have that ability brought back - for paying and for writing off fines.  I'm not sure about whether they want to be able to edit that note after the fact, but if it were possible I'm sure no one would complain.  Most important thing is allowing people to make notes/memos on payments/writeoffs.

Nicole
Comment 7 Chris Hall 2012-01-26 03:24:54 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2012-02-06 20:33:28 UTC
Attempted testing of this patch, does not appear to work completely. Applies cleanly.

1) I created a series of manual invoices with notes, those notes appear in the Note column on boraccount.pl

2) Switch to pay.pl. Here, the Payment Note column appears with a text box, but does not pull over the fine note ( I'm not sure if that is supposed to be part of the functionality or not, but I thought I'd mention it ).

4) Tested with pay, writeoff, and writeoff all buttons, works as stated.

HOWEVER, everything gets broken and messed up if special characters are used in *any* of the notes fields. 

The data being passed is not being url encoded properly. 

For example, if I make the payment note "Test Payment #12 Note", the payment note will be "Test Payment ". It gets truncated at the special character. If you look at the passed params, you will see "payment_note=Test Payment #12 Note" rather than "payment_note=Test%20Payment%20%2312%20Note", as it should be. 

It gets worse if you used special characters in the Description of charges, or the Note field. In that case, no part of the note will show up, as everything is truncated at the special character even earlier.

So, patch essentially works, but everything needs to be url encoded properly or librarians will not understand why their notes aren't showing up correctly.
Comment 9 Chris Hall 2012-02-08 01:17:09 UTC Comment hidden (obsolete)
Comment 10 Kyle M Hall 2012-02-15 13:33:04 UTC
Applying: Bug 6413 Added ability to add a note when paying or writing off a fine Code will also respect notes when using the "Writeoff All" button but WILL NOT when using either the "Pay Amount" or "Pay Selected" buttons Fixed uri encoding of arguments
/home/koha/kohaclone/.git/rebase-apply/patch:77: trailing whitespace.
    <th>Payment Note</th>   
/home/koha/kohaclone/.git/rebase-apply/patch:217: trailing whitespace.
            if ( $total_paid == $total_due ) { 
error: patch failed: C4/Accounts.pm:197
error: C4/Accounts.pm: patch does not apply
Comment 11 Chris Hall 2012-04-11 04:46:34 UTC Comment hidden (obsolete)
Comment 12 Nicole C. Engard 2012-04-11 17:42:05 UTC
nengard@kohavm:~/kohaclone$ git bz apply 6413
Bug 6413 - Notes in Fines doing wonky things

Added ability to add notes when paying or writing off fines
Apply? [yn] y

Applying: Bug 6413 Added ability to add a note when paying or writing off a fine Code will also respect notes when using the "Writeoff All" button but WILL NOT when using either the "Pay Amount" or "Pay Selected" buttons Fixed uri encoding of arguments
/home/nengard/kohaclone/.git/rebase-apply/patch:121: trailing whitespace.
    <th>Payment Note</th>   
/home/nengard/kohaclone/.git/rebase-apply/patch:231: trailing whitespace.
            if ( $total_paid == $total_due ) { 
error: patch failed: koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt:47
error: koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt: patch does not apply
Patch failed at 0001 Bug 6413 Added ability to add a note when paying or writing off a fine Code will also respect notes when using the "Writeoff All" button but WILL NOT when using either the "Pay Amount" or "Pay Selected" buttons Fixed uri encoding of arguments
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
Patch left in /tmp/Added-ability-to-add-notes-when-paying-or-writing--sDFuBJ.patch
nengard@kohavm:~/kohaclone$
Comment 13 Chris Cormack 2012-04-11 21:07:42 UTC
Did you remember to try applying it with a 3 way merge

git bz is cool, but without the patch from paul, it doesnt try to merge. 

git am --abort
 git am -iu3 /tmp/Added-ability-to-add-notes-when-paying-or-writing--E9jlEe.patch

Found out it was a tiny conflict because of the capitalisation change, in one file. Fixed that, reattached.

But if git bz fails, please try git am -iu3 before marking does not apply, if that still fails, then that's fine. But a lot of the times it passes
Comment 14 Chris Cormack 2012-04-11 21:10:30 UTC Comment hidden (obsolete)
Comment 15 Nicole C. Engard 2012-04-12 12:26:19 UTC Comment hidden (obsolete)
Comment 16 Nicole C. Engard 2012-04-12 12:26:56 UTC
A future dev for this would be to allow notes when using the buttons at the bottom .. but this works as explained and is a great step in the right direction!
Comment 17 Ian Walls 2012-04-16 15:07:17 UTC
Adds payment_note param to makepayment(), makepartialpayment() and WriteOffFee().  Additional param is at the end, and is safely added (defined to '' if nothing is passed)

Introduces a new string to members/pay.tt... RM, your call as to whether that's a blocker for 3.8 or not.

Otherwise, looks good, marking Passed QA.
Comment 18 Chris Hall 2012-04-16 20:58:43 UTC Comment hidden (obsolete)
Comment 19 Nicole C. Engard 2012-04-17 01:19:09 UTC Comment hidden (obsolete)
Comment 20 Nicole C. Engard 2012-04-17 01:19:38 UTC
signed off on typo fix.
Comment 21 Paul Poulain 2012-04-18 16:13:10 UTC
This patch changes some string, so i'm not inclined to push it for 3.8, plus there's a (tiny) failed QA problem: Payment Note => should be Payment note.

I continue checking other patches that passed QA, will decide later if it's better to push it
Comment 22 Paul Poulain 2012-04-18 16:13:59 UTC
(note that "Payment note" string does not exist yet in the translation tables, so it won't be translated if I push)
Comment 23 Paul Poulain 2012-04-30 16:13:10 UTC
QA comment: if you use the 'pay amount' button, any comment you've entered is lost. I think this is quite inconsistent.

Any explanation welcomed, maybe that's an ergonomic problem (mixing pay line by line, with comment added, and pay all at once is illogic)

Marking failed QA for now, not that I refuse the patch, but fixes a problem and I think introduces another one...
Comment 24 Paul Poulain 2012-04-30 16:13:43 UTC Comment hidden (obsolete)
Comment 25 Nicole C. Engard 2012-04-30 20:45:40 UTC
I agree that when paying all or paying selected the notes should stay - but it's not a new bug as much as it's a feature that never existed. So I'd love to see that feature added :)
Comment 26 Chris Hall 2012-04-30 21:38:47 UTC
Hey Guys

I agree that all the buttons should behave in a similar way and that this could be confusing.

However for both pay amount and pay selected the way they are handled is quite differently to the other buttons, everything (either everything selected or everything) in the form is encoded into a one dimensional array that is then encoded as a single string and this is then passed back and forth between multiple scripts.

This is quite messy to deal with and get right and would significantly increase the size and complexity of the patch.
Comment 27 Nicole C. Engard 2012-05-08 13:04:56 UTC
Like I said, I'm with Chris, I don't think this should fail QA. The reason you're failing it is a feature that never existed, Chris's patch just fixes a feature that did exist and was broken.
Comment 28 Paul Poulain 2012-05-21 14:37:15 UTC
(In reply to comment #13)
> Did you remember to try applying it with a 3 way merge
> 
> git bz is cool, but without the patch from paul, it doesnt try to merge.

Just as a reminder, the patch is here:
https://depot.biblibre.com/ppoulain/0001-Add-3-parameter-to-git-am.patch

(otherwise, checking this patch again, to see if I was wrong refusing QA, or arguing a little bit more to justify)
Comment 29 Paul Poulain 2012-05-21 15:36:45 UTC
After testing again, I confirm my failed QA:
 * add 2 manual invoices, say 1€ and 2€
 * head to "Pay fine" (pay.pl) tab
 * you can:
   - check or uncheck a line
   - add a comment on each line
 * uncheck line 2€, keep line 1€ checked, add a note to line 1€
 * clic "Pay selected": you are asked to pay 1€, if you save,the comment you've entered is not saved

I also tried to reproduce the behaviour shown on http://screencast.com/t/bPYEhgtAj, but since the bug 3498 Allow partial payments of fines, things have changed, and I can't reproduce the buggy behaviour.
Comment 30 Martin Renvoize 2012-05-29 14:25:46 UTC
*** Bug 7004 has been marked as a duplicate of this bug. ***
Comment 31 Nicole C. Engard 2012-08-09 15:12:41 UTC
Chris,

Can you submit a new patch that will pass QA on this?

Nicole
Comment 32 Liz Rea 2012-08-09 15:16:50 UTC
This patch no longer applies :(
Comment 33 Kyle M Hall 2012-10-03 13:12:40 UTC Comment hidden (obsolete)
Comment 34 Kyle M Hall 2012-10-03 13:43:56 UTC Comment hidden (obsolete)
Comment 35 Mason James 2012-10-03 23:55:11 UTC Comment hidden (obsolete)
Comment 36 Mason James 2012-10-03 23:55:32 UTC Comment hidden (obsolete)
Comment 37 Mason James 2012-10-04 00:14:51 UTC
(In reply to comment #36)
> Created attachment 12669 [details] [review]
> Bug 6413 Added ability to add a note when paying or writing off a fine
> 
> Code will also respect notes when using the "Writeoff All" button but WILL
> NOT when using either the "Pay Amount" or "Pay Selected" buttons Fixed uri
> encoding of arguments
> 
> Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>

2 patches test as expected, passing QA...

$ koha-qa.pl -c 2
testing 2 commit(s) (applied to commit 6c18204)
 * c1c9900 Bug 6413 follow-up: fixing capital case & tabs
      koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt

 * 66cfbba Bug 6413 Added ability to add a note when paying or writing off a fine
      C4/Accounts.pm
      koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt
      koha-tmpl/intranet-tmpl/prog/en/modules/members/paycollect.tt
      members/pay.pl
      members/paycollect.pl

* C4/Accounts.pm                                                           OK
* members/pay.pl                                                           OK
* members/paycollect.pl                                                    OK
* koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt                   OK
* koha-tmpl/intranet-tmpl/prog/en/modules/members/paycollect.tt            OK
Comment 38 Paul Poulain 2012-10-08 14:42:27 UTC
Sorry guys (& girls), but the problem I've explained in comment 29 is still here:
(In reply to comment #29)
> After testing again, I confirm my failed QA:
>  * add 2 manual invoices, say 1€ and 2€
>  * head to "Pay fine" (pay.pl) tab
>  * you can:
>    - check or uncheck a line
>    - add a comment on each line
>  * uncheck line 2€, keep line 1€ checked, add a note to line 1€
>  * clic "Pay selected": you are asked to pay 1€, if you save,the comment
> you've entered is not saved

I also see wrong HTML:
+    <td><input type="text" name="payment_note_[% line.accountno %]"></input></td>

should be written 
<td><input type="text" name="payment_note_[% line.accountno %]" /></td>
(self closed html tag)
Comment 39 Melia Meggs 2013-01-04 21:46:43 UTC
Just a nudge - is anyone working on a new patch that addresses Paul's QA comments, by chance?
Comment 40 Paul Poulain 2013-01-18 10:27:38 UTC
(In reply to comment #39)
> Just a nudge - is anyone working on a new patch that addresses Paul's QA
> comments, by chance?

seems no...
Comment 41 Kyle M Hall 2013-01-24 19:02:45 UTC Comment hidden (obsolete)
Comment 42 Kyle M Hall 2013-01-24 19:04:32 UTC Comment hidden (obsolete)
Comment 43 Kyle M Hall 2013-01-24 19:05:09 UTC
Is this what you were asking for? ^

(In reply to comment #40)
> (In reply to comment #39)
> > Just a nudge - is anyone working on a new patch that addresses Paul's QA
> > comments, by chance?
> 
> seems no...
Comment 44 Kyle M Hall 2013-01-24 19:07:38 UTC Comment hidden (obsolete)
Comment 45 Kyle M Hall 2013-01-24 19:08:41 UTC
Followup is super trivial, switching to signed-off. QA can decide if another SO is necessary.
Comment 46 Kyle M Hall 2013-01-24 20:45:11 UTC Comment hidden (obsolete)
Comment 47 Kyle M Hall 2013-01-25 12:43:31 UTC Comment hidden (obsolete)
Comment 48 Owen Leonard 2013-01-28 14:42:00 UTC
Can someone provide a test plan for this? Can the last three patches be squashed?
Comment 49 Owen Leonard 2013-01-28 14:45:27 UTC
Also, is the title of this bug accurate with regard to what the patches are for?
Comment 50 Kyle M Hall 2013-01-28 14:46:58 UTC Comment hidden (obsolete)
Comment 51 Kyle M Hall 2013-01-28 14:47:20 UTC Comment hidden (obsolete)
Comment 52 Kyle M Hall 2013-01-28 14:54:35 UTC
(In reply to comment #49)
> Also, is the title of this bug accurate with regard to what the patches are
> for?

The middle one is from Paul, but I squashed my two together. Nicole mentioned the lack of the note field in her initial comment, but it might be better to change the title to something like "Add note fields for fine payments".

Test plan:
1) Apply the patches
2) Create some test fees
3) Pick two or more to use for the 'Pay selected' option, add notes for each
4) Click 'pay selected'
5) The notes for each selected fee should be pulled into the new 'notes' text field on paycollect.pl. Here you can modify the imported notes if you wish before clicking "Confirm"
6) Confirm the note for the payment is now displayed on boraccount.pl for the payment.
Comment 53 Owen Leonard 2013-01-28 16:23:43 UTC
I'm ready to sign off except for one small bug: The table columns are now out of sync with the footer. Sub total and total due should be aligned with the last column.
Comment 54 Kyle M Hall 2013-01-28 16:56:33 UTC Comment hidden (obsolete)
Comment 55 Kyle M Hall 2013-01-28 16:57:29 UTC
Fixed!

(In reply to comment #53)
> I'm ready to sign off except for one small bug: The table columns are now
> out of sync with the footer. Sub total and total due should be aligned with
> the last column.
Comment 56 Owen Leonard 2013-01-28 17:31:16 UTC Comment hidden (obsolete)
Comment 57 Katrin Fischer 2013-02-11 07:00:03 UTC
The patch conflicts now because the fix for recording payments in the logs.
Kyle or Chris - can you please resolve the conflicts?
Comment 58 Kyle M Hall 2013-02-11 12:48:07 UTC Comment hidden (obsolete)
Comment 59 Kyle M Hall 2013-02-11 12:48:47 UTC Comment hidden (obsolete)
Comment 60 Kyle M Hall 2013-02-11 12:49:34 UTC Comment hidden (obsolete)
Comment 61 Paul Poulain 2013-03-20 10:47:23 UTC
QA comment :
 * small conflict i've fixed
 * still passes koha-qa
 * the bugguy behaviour I saw in comment 29 is fixed
 * no other comment

passed QA !
Comment 62 Paul Poulain 2013-03-20 10:48:35 UTC Comment hidden (obsolete)
Comment 63 Paul Poulain 2013-03-20 10:53:15 UTC
Created attachment 16487 [details] [review]
[PASSED QA]Bug 6413 Added ability to add a note when paying or writing off a fine

Code will also respect notes when using the "Writeoff All" button but WILL NOT when using either the "Pay Amount" or "Pay Selected" buttons Fixed uri encoding of arguments

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 64 Paul Poulain 2013-03-20 10:53:25 UTC
Created attachment 16488 [details] [review]
[PASSED QA]Bug 6413 follow-up: fixing capital case & tabs

* switching from "Payment Note" to "Payment note"
* replaced tabs by 4 spaces in lines just before and after this fix, for consistent indenting

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 65 Paul Poulain 2013-03-20 10:53:30 UTC
Created attachment 16489 [details] [review]
[PASSED QA]Bug 6413 - QA Followup - Add notes for 'Pay selected'

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 66 Jared Camins-Esakov 2013-03-20 12:15:37 UTC
This patch breaks the table on the Pay fines tab: http://screencast.com/t/YgcrEjHqBCU
Comment 67 Kyle M Hall 2013-05-08 16:42:25 UTC
Created attachment 18035 [details] [review]
Bug 6413 - QA Followup - Remove extra table column header

Trivial fix, switching back to passed qa.
Comment 68 Jared Camins-Esakov 2013-05-09 00:43:43 UTC
This patch has string changes and will therefore be held for 3.14.
Comment 69 Galen Charlton 2013-05-21 23:55:31 UTC
Pushed to master.  Thanks, Chris, Paul, and Kyle!