Bug 6463 - Authorities browsing error when using auth. plugins
Summary: Authorities browsing error when using auth. plugins
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Janusz Kaczmarek
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5917
  Show dependency treegraph
 
Reported: 2011-06-05 16:32 UTC by Janusz Kaczmarek
Modified: 2012-10-25 23:10 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
A screenshot illustrating the problem (50.68 KB, image/png)
2011-06-05 16:32 UTC, Janusz Kaczmarek
Details
Proposed patch (3.42 KB, patch)
2011-06-05 16:39 UTC, Janusz Kaczmarek
Details | Diff | Splinter Review
Signed-off patch (3.78 KB, patch)
2011-06-05 18:54 UTC, Frédéric Demians
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Janusz Kaczmarek 2011-06-05 16:32:23 UTC
Created attachment 4364 [details]
A screenshot illustrating the problem

The problem is as follows:

1. Add new record
2. Go to a field controlled by authority
3. Click on ...
4. Search for such a term to get many results
5. Try to browse to next page

The result should be Error 500, as on the attached screenshot. (Tested on UNIMARC with 606).

This is due to erroneous variable prefixing in transition to T::T. 

A patch will come.
Comment 1 Janusz Kaczmarek 2011-06-05 16:39:58 UTC Comment hidden (obsolete)
Comment 2 Frédéric Demians 2011-06-05 18:52:23 UTC
I confirm the solution. On my test UNIMARC installation, I haven't an
error 500 but I have a wrong result pages navigation bar which doesn't
limit search result on the selected authority type.
Comment 3 Frédéric Demians 2011-06-05 18:54:05 UTC
Created attachment 4368 [details] [review]
Signed-off patch
Comment 4 Chris Cormack 2011-06-09 23:06:49 UTC
TT bug, pushed please test