Bug 6496 - authors appearing incorrectly in OPAC and Staff Client
Summary: authors appearing incorrectly in OPAC and Staff Client
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: 3.6
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Robin Sheat
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-13 17:23 UTC by Nicole C. Engard
Modified: 2013-12-05 20:05 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
opac with dots (64.32 KB, image/png)
2011-06-13 17:23 UTC, Nicole C. Engard
Details
opac with hyphens (xslt off) (61.57 KB, image/png)
2011-06-13 17:23 UTC, Nicole C. Engard
Details
order of fields in opac (66.39 KB, image/png)
2011-06-13 17:23 UTC, Nicole C. Engard
Details
order of fields in opac (marc view) (128.97 KB, image/png)
2011-06-13 17:24 UTC, Nicole C. Engard
Details
Bug 6496 - tidy the display of 710 fields on XSLT (3.03 KB, patch)
2011-08-31 08:03 UTC, Robin Sheat
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6496 - tidy the display of 710 fields on XSLT (3.10 KB, patch)
2011-09-07 17:00 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Before shot, showing the current (incorrect) ordering display on the OPAC (28.06 KB, image/png)
2011-09-12 02:07 UTC, Robin Sheat
Details
After shot, showing the new (correct) ordering display on the OPAC (16.24 KB, image/png)
2011-09-12 04:21 UTC, Robin Sheat
Details
Bug 6496 - correct the order of the author display in the OPAC (7.41 KB, patch)
2011-09-12 04:30 UTC, Robin Sheat
Details | Diff | Splinter Review
Bug 6496 - correct the order of the author display in the OPAC (7.48 KB, patch)
2011-09-12 23:13 UTC, Robin Sheat
Details | Diff | Splinter Review
screenshot of opac (51.24 KB, image/png)
2011-09-18 18:43 UTC, Katrin Fischer
Details
Bug 6496 - correct the order of the author display in the OPAC (7.61 KB, patch)
2012-02-02 05:22 UTC, Robin Sheat
Details | Diff | Splinter Review
Bug 6496 - tidy the display of 710 fields on XSLT (3.20 KB, patch)
2012-02-07 15:50 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 6496 - correct the order of the author display in the OPAC (7.72 KB, patch)
2012-02-07 15:51 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-06-13 17:23:04 UTC
Created attachment 4447 [details]
opac with dots

In the staff client if the additional author (7xx) has multiple parts it's putting dots in between the parts if XSLT is on and hyphens if it's off.  It's easier to read with the hyphens. In the OPAC there are dots and no spaces and it's all smooched up.  See attached.  It should probably be hyphens or spaces instead of dots.

Also some strangeness is happening with the order of authors. In the staff client when you have XSLT on additional authors are clearly on another line (easy to read) but in the OPAC, things aren't coming through right.  In the OPAC the 100s are first then the 700s and then the 110s and then the 710s ... it should be all 1xxs and then all 7xxs (preferrably with the relator code showing so you know if it's an editor or illustrator) - at the very least the order should be fixed in this way.  

My screenshots show this all for you on my very bad marc record :)
Comment 1 Nicole C. Engard 2011-06-13 17:23:38 UTC
Created attachment 4448 [details]
opac with hyphens (xslt off)
Comment 2 Nicole C. Engard 2011-06-13 17:23:57 UTC
Created attachment 4449 [details]
order of fields in opac
Comment 3 Nicole C. Engard 2011-06-13 17:24:12 UTC
Created attachment 4450 [details]
order of fields in opac (marc view)
Comment 4 Robin Sheat 2011-08-31 05:57:11 UTC
Attaching MARC records for this kind of thing makes checking it easier, although I'm sure I can make one up easily in this case :)
Comment 5 Robin Sheat 2011-08-31 06:42:06 UTC
Staff client without XSLT: looks nice, uses '--' to split up 
Staff client with XSLT: they are all joined up, no spaces, which is ugly.

OPAC without XSLT: looks nice, uses '--' to split up
OPAC with XSLT: all joined up, no spaces, ugly.

I'll check out the order thing separately, probably as a patch on top of one that fixes the layout.
Comment 6 Robin Sheat 2011-08-31 08:03:20 UTC Comment hidden (obsolete)
Comment 7 Robin Sheat 2011-08-31 08:08:06 UTC
Oh, this patch doesn't address the ordering thing.
Comment 8 Nicole C. Engard 2011-09-07 17:00:59 UTC Comment hidden (obsolete)
Comment 9 Nicole C. Engard 2011-09-07 17:01:32 UTC
A follow up is still necessary for the ordering, but this first patch does fix the display aspect so I have signed off on it.

Nicole
Comment 10 Robin Sheat 2011-09-12 02:07:21 UTC
Created attachment 5397 [details]
Before shot, showing the current (incorrect) ordering display on the OPAC
Comment 11 Robin Sheat 2011-09-12 04:21:02 UTC
Created attachment 5399 [details]
After shot, showing the new (correct) ordering display on the OPAC
Comment 12 Robin Sheat 2011-09-12 04:30:23 UTC Comment hidden (obsolete)
Comment 13 Robin Sheat 2011-09-12 04:35:11 UTC
Actually, a comment I failed to add to the commit...it doesn't display it in numerical order, it displays it in the order in the MARC, which typically is the correct order. Let me know if this is an issue and I'll puzzle out making it sort.
Comment 14 Robin Sheat 2011-09-12 04:46:40 UTC
Also, this is intended to go on top of the signed-off patch. If that's not done, it probably won't apply.
Comment 15 Robin Sheat 2011-09-12 23:13:10 UTC Comment hidden (obsolete)
Comment 16 Katrin Fischer 2011-09-18 18:43:16 UTC
Created attachment 5451 [details]
screenshot of opac

I applied both patches and tried cataloging a record with 100, 110, 700 and 710. I am not sure, I did it right. The order seems right to me, it's 100, 110, 700, 710.
I think an additional space is missing after 110, to make it _;_ consistently.
Comment 17 Robin Sheat 2011-09-18 20:43:55 UTC
It's always inserting '; ', which I think was taken from the staff client implementation (although I'd have to double check that.) It has no special handling of the 110 field.

This suggests to me that all your other fields have a trailing space as part of their record. I'm not sure what the cataloguing spec says here, should we put a trailing space in, or not? Are the records expected to have one?

It's a very easy change to add a space.
Comment 18 Katrin Fischer 2011-09-18 20:54:30 UTC
I added authorities and linked them in cataloging. I checked my authorities and the record and can't find any trailing spaces.
Comment 19 Robin Sheat 2011-09-18 21:23:46 UTC
Hmm, now I think of it, my records won't have trailing spaces, but are not done with authorities. Are all of yours authorities, or just the 110? Is the 710 done with authorities too? Can you add a 711 field, I want to see if the 710 shows the same behaviour (as it follows exactly the same codepath as the 110.)
Comment 20 Nicole C. Engard 2011-09-26 14:51:17 UTC
Robin,

Does this obsolete my signed off patch or is it a follow up?

Nicole

(In reply to comment #15)
> Created attachment 5409 [details] [review]
> Bug 6496 - correct the order of the author display in the OPAC
> 
> This sets the order the fields are displayed in to be as it is in the
> MARC (typically numerical order), rather than 100,700,110,710,... like
> it was.
> 
> Basically, it's a port of the way it's done in the staff client. As
> such, it should be able to handle a lot more than it could previously,
> including relator codes.
> 
> (replaces the previous commit, just removing an erronious comment and
> making the commit message more accurate)
Comment 21 Robin Sheat 2011-09-26 20:10:54 UTC
It's a followup, the signed-off one does the separator characters, this one does the ordering.
Comment 22 Owen Leonard 2011-11-04 20:18:17 UTC
[SIGNED-OFF] Bug 6496 - tidy the display of 710 fields on XSLT
Apply? [yn] y

Applying: Bug 6496 - tidy the display of 710 fields on XSLT
Bug 6496 - correct the order of the author display in the OPAC
Apply? [yn] y

Applying: Bug 6496 - correct the order of the author display in the OPAC
error: patch failed: koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl:128
error: koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl: patch does not apply
Patch failed at 0001 Bug 6496 - correct the order of the author display in the OPAC
Comment 23 Nicole C. Engard 2011-11-11 14:38:07 UTC
I can confirm that this follow up still does not apply:

nengard@debian:~/kohaclone$ git bz apply 6496
Bug 6496 - authors appearing incorrectly in OPAC and Staff Client

[SIGNED-OFF] Bug 6496 - tidy the display of 710 fields on XSLT
Apply? [yn] n
Bug 6496 - correct the order of the author display in the OPAC
Apply? [yn] y

Applying: Bug 6496 - correct the order of the author display in the OPAC
error: patch failed: koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl:128
error: koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl: patch does not apply
Patch failed at 0001 Bug 6496 - correct the order of the author display in the OPAC
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
Patch left in /tmp/Bug-6496---correct-the-order-of-the-author-display-6K4Z4g.patch
nengard@debian:~/kohaclone$
Comment 24 Katrin Fischer 2011-11-11 14:45:36 UTC
Hi Nicole, 
only a note: git bz apply does not use the -3 option. Sometimes the patch will apply when you do a git am -is3 /tmp....
Comment 25 Nicole C. Engard 2011-11-11 15:01:05 UTC
No such luck:

Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: Bug 6496 - correct the order of the author display in the OPAC
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl
CONFLICT (content): Merge conflict in koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl
Failed to merge in the changes.
Patch failed at 0001 Bug 6496 - correct the order of the author display in the OPAC
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
nengard@debian:~/kohaclone$
Comment 26 Robin Sheat 2012-02-02 05:22:43 UTC Comment hidden (obsolete)
Comment 27 Robin Sheat 2012-02-02 05:23:30 UTC
Rebased so that it applies.
Comment 28 Jared Camins-Esakov 2012-02-07 15:50:55 UTC
Created attachment 7479 [details] [review]
Bug 6496 - tidy the display of 710 fields on XSLT

This puts '--' between 710$b fields, and replaces the '.' with a '; ' if
there are additional authors.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Comment 29 Jared Camins-Esakov 2012-02-07 15:51:21 UTC
Created attachment 7480 [details] [review]
Bug 6496 - correct the order of the author display in the OPAC

This sets the order the fields are displayed in to be as it is in the
MARC (typically numerical order), rather than 100,700,110,710,... like
it was.

Basically, it's a port of the way it's done in the staff client. As
such, it should be able to handle a lot more than it could previously,
including relator codes.

(replaces the previous commit, just removing an erronious comment and
making the commit message more accurate)

Conflicts:

	koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACDetail.xsl

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Comment 30 Paul Poulain 2012-02-17 17:57:27 UTC
QA comment: XSLT changes only, MARC21 specific, nothing to say

passed QA
Comment 31 Jared Camins-Esakov 2012-12-31 00:39:01 UTC
There have been no further reports of problems so I am marking this bug resolved.