Bug 6513 - Library and Category filters when searching for a borrower to add to a routing list don't work correctly.
Summary: Library and Category filters when searching for a borrower to add to a routin...
Status: RESOLVED DUPLICATE of bug 13891
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P2 normal (vote)
Assignee: Robin Sheat
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 00:03 UTC by Robin Sheat
Modified: 2016-02-15 17:31 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6513 - make the routing list search work properly, and faster too. (11.19 KB, patch)
2011-06-20 06:06 UTC, Robin Sheat
Details | Diff | Splinter Review
Bug 6513 - ensure the subscription ID gets carried across (2.18 KB, patch)
2011-06-20 07:06 UTC, Robin Sheat
Details | Diff | Splinter Review
[Signed Off] Bug 6513 - make the routing list search work properly, and faster too. (11.28 KB, patch)
2011-08-05 18:25 UTC, Liz Rea
Details | Diff | Splinter Review
[Signed Off] Bug 6513 - ensure the subscription ID gets carried across (2.27 KB, patch)
2011-08-05 18:27 UTC, Liz Rea
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2011-06-17 00:03:55 UTC
To reproduce:

1)
* Put a borrower's name in the box
* Leave the other two fields as "any"
* This works correctly

2)
* Put a borrower's name in the box
* Set the "Library" field to a library, the "Category" field as "any"
* This provides you all the borrowers in that library, ignoring the borrower's name.

3) 
* Repeat the above with a category set.
* Note that the category doesn't affect the output at all.
Comment 1 Robin Sheat 2011-06-20 06:06:00 UTC Comment hidden (obsolete)
Comment 2 Robin Sheat 2011-06-20 07:06:19 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2011-08-05 18:25:46 UTC
Created attachment 4870 [details] [review]
[Signed Off] Bug 6513 - make the routing list search work properly, and faster too.

Signed-off-by: Liz Rea <lrea@nekls.org>
Comment 4 Liz Rea 2011-08-05 18:27:14 UTC
Created attachment 4871 [details] [review]
[Signed Off] Bug 6513 - ensure the subscription ID gets carried across

Signed-off-by: Liz Rea <lrea@nekls.org>
Comment 5 Ian Walls 2011-08-29 21:22:54 UTC
SQL in FindPartialName is unlimited, which could cause system slowness for large databases and generic queries.  For this reason I mark it as Failed QA.

The addition of a third patron search subroutine is counter to bug 6253, which is a sponsored change to bring Search and SearchMember together into a single, robust search routine.  I would prefer to see the search for patrons in the serials routing list area use the same search routine as everywhere else (with different parameters passed as necessary), but I solicit community feedback on this.  Should another patron search subroutine be allowed, if it solves this particular issue?
Comment 6 Katrin Fischer 2012-02-19 12:38:27 UTC
I confirm the search is still broken on current master, changing version to reflect this.
Attached patches do no longer apply.
Comment 7 Robin Sheat 2012-06-25 14:17:56 UTC
It would make the most sense for this to be modified to use existing patron search stuff, if it's possible for that to have filters too (or, we could apply the filters post-hoc I guess.)
Comment 8 Katrin Fischer 2014-11-10 10:25:18 UTC
This is still valid.
Comment 9 Jonathan Druart 2014-11-10 10:38:03 UTC
Bug 13021 and bug 12648 use the member search webservice.
When they will be pushed, maybe this one will be easy to implement using the same way.
Comment 10 Robin Sheat 2014-11-11 00:30:14 UTC
Erg, which I'd noticed this earlier, it would have been very easy to slap a 'LIMIT 20' or something onto the SQL. However now it probably doesn't apply.
Comment 11 Jonathan Druart 2016-02-15 17:30:47 UTC
Should have been fixed by bug 13891.

*** This bug has been marked as a duplicate of bug 13891 ***
Comment 12 Jonathan Druart 2016-02-15 17:31:14 UTC
commit a77a9a70a232c3b2839945638df0f73aa9610327
    Bug 13891: DataTables server-side processing - Serial recipients