Bug 6542 - Degree symbol causes error in cataloging in IE
Summary: Degree symbol causes error in cataloging in IE
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-29 16:40 UTC by Nicole C. Engard
Modified: 2015-06-04 23:23 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-06-29 16:40:36 UTC
Copying and pasting the degree symbol into the abstract field seems to cause the following error in IE, but not in FF.

Software error:
Can't call method "fields" on an undefined value at
/home/koha/kohaclone/C4/Biblio.pm line 2101.
Comment 1 Owen Leonard 2011-07-07 13:38:14 UTC
I couldn't reproduce this in IE8 on Windows 7. I added a degree symbol (Unicode character U+00B0, Windows keystroke Alt+0176) to 5xx fields and was able to save the record without error.
Comment 2 Ian Walls 2011-07-11 15:04:39 UTC
This could be an issue with Unicode normalization... NFC v. NFD...
Comment 3 wajasu 2012-09-10 21:28:56 UTC
I did the same as Owen and no problems saving.  Maybe some NFC work done after 2012-06-29 has fixed it.   I Used IE 8 on Win7.
Comment 4 Owen Leonard 2014-07-18 14:33:38 UTC
Two attempts to reproduce this bug failed. I'm going to consider this fixed. Please re-open if you can provide more details about how to reproduce.