Bug 6589 - can't add supplements
Summary: can't add supplements
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Colin Campbell
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5917
  Show dependency treegraph
 
Reported: 2011-07-14 19:41 UTC by Nicole C. Engard
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (2.51 KB, patch)
2011-07-16 20:18 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-07-14 19:41:21 UTC
When trying to add a supplement I get this error:

Software error:

mismatched tag at line 7, column 2, byte 273 at /usr/lib/perl5/XML/Parser.pm line 187
Comment 1 Katrin Fischer 2011-07-16 19:20:13 UTC
I can reproduce this error when adding supplements for subscriptions set to 'create items' on current master.
Comment 2 Katrin Fischer 2011-07-16 20:18:01 UTC
Created attachment 4640 [details] [review]
Proposed patch

To test:
- add a new subscription, choose 'create items on receive'
- receive some issues and create items > should work ok
- create a supplement, alone or at the same time as receiving a normal issue
- check if item was created and attached to the biblio record

Without patch this should give you an error message. Although supplement will be created, no item will be added to the bibliogrpahic record.

With patch applied there should be no error message and the item should be created and attached to the proper record.
Comment 3 Ian Walls 2011-07-18 18:01:53 UTC
Easy patch to read, related to T:T issues.  Since the test plan is clear, and this has been signed off (July 16 by nengard, see patches list), I will mark this as Passed QA.
Comment 4 Chris Cormack 2011-07-19 07:24:04 UTC
Pushed, please test
Comment 5 Ian Walls 2011-10-16 11:40:51 UTC
Marking resolved