Bug 6668 - Marc batch edit will freeze after deselecting all items and saving,
Summary: Marc batch edit will freeze after deselecting all items and saving,
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.4
Hardware: PC Windows
: P5 - low minor (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 14:32 UTC by stevecallender
Modified: 2015-06-04 23:23 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stevecallender 2011-08-04 14:32:34 UTC
After applying patches for bugs 6446 and 6543 to fix the "Batch item modification" from freezing when trying to save, there is still an issue, albeit minor. 

When deselecting all items for batch editing, and then saving, the progress bar changes to NaN% and nothing happens. The code should recognize that the user is attempting to save 0 items and complain about such, rather than just freeze.
Comment 1 Owen Leonard 2014-07-16 21:55:11 UTC
Bug 6446 and But 6543 referenced above are both closed and I cannot reproduce this problem in master.