Bug 6687 - cannot move people in the holds queue
Summary: cannot move people in the holds queue
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Robin Sheat
QA Contact: Bugs List
URL: cgi-bin/koha/reserve/request.pl?bibli...
Keywords:
Depends on: 6526
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-09 15:34 UTC by Nicole C. Engard
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6687 - allow people to be moved in the holds queue (14.67 KB, patch)
2011-09-07 01:50 UTC, Robin Sheat
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6687 - allow people to be moved in the holds queue (14.74 KB, patch)
2011-09-07 15:44 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-08-09 15:34:59 UTC
When viewing the holds queue clicking the arrows to move people around the queue causes an error message saying that the patron already has the item on hold.

"Cannot Place Hold
    Olga Rivera already has a hold on this item"

This could be a T:T issue (actually I hope it is).
Comment 1 Owen Leonard 2011-08-09 15:58:08 UTC
I rolled back reserve/request.pl to the state it was in before Bug 6526 and found that the arrows were working again. I'm guessing a change in that patch (now pushed) is the cause.
Comment 2 Liz Rea 2011-09-06 16:21:39 UTC
I agree with owen's assessment.
Comment 3 Robin Sheat 2011-09-06 23:58:05 UTC
Rats, I guess that'll make it my problem then.
Comment 4 Robin Sheat 2011-09-07 01:27:22 UTC
I note that the change does apply, it's just also putting up the error message. (still going to fix it proper though.)
Comment 5 Robin Sheat 2011-09-07 01:50:03 UTC Comment hidden (obsolete)
Comment 6 Nicole C. Engard 2011-09-07 15:44:11 UTC
Created attachment 5340 [details] [review]
[SIGNED-OFF] Bug 6687 - allow people to be moved in the holds queue

This fixes a regression introduced by Bug 6526 that told you someone
already had a reserve if you attempted to move their ordering in the
hold queue.

(note: it also cleans a host of trailing whitespace errors that were in
that file)

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Comment 7 Ian Walls 2011-09-07 15:48:20 UTC
Primarily white space changes, which are okay.  The core content of the file adds a simple additional check to the conditional, which seems okay.  Marking as Passed QA
Comment 8 Chris Cormack 2011-09-08 01:50:02 UTC
Pushed, please test
Comment 9 Liz Rea 2011-09-20 21:43:44 UTC
Works great, thanks!