Bug 6765 - Enable correct checksums for UTF-8 encoded data
Summary: Enable correct checksums for UTF-8 encoded data
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: 3.4
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: Ulrich Kleiber
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 4828 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-23 15:09 UTC by Ulrich Kleiber
Modified: 2012-10-25 23:09 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
proposed patch (1.02 KB, patch)
2011-08-23 15:21 UTC, Ulrich Kleiber
Details | Diff | Splinter Review
Signed off Patch (1.29 KB, patch)
2011-08-26 16:29 UTC, Ian Walls
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Kleiber 2011-08-23 15:09:47 UTC
Problem description/solution by Dan Scott:

http://sourceforge.net/tracker/?func=detail&aid=2925760&group_id=161781&atid=821216
Comment 1 Ulrich Kleiber 2011-08-23 15:21:20 UTC Comment hidden (obsolete)
Comment 2 Ian Walls 2011-08-26 16:29:14 UTC
Created attachment 5164 [details] [review]
Signed off Patch
Comment 3 Ian Walls 2011-08-26 16:33:18 UTC
Going to be shady and jump this one straight from "needs signoff" to "Passed QA".  Testing has been done on a live library partner of ByWaters, and reports are 100% positive on a variety of diacritical characters.

As always, if anyone is uncomfortable with my decision, please respond here.
Comment 4 Ian Walls 2011-08-26 16:34:41 UTC
*** Bug 4828 has been marked as a duplicate of this bug. ***
Comment 5 Chris Cormack 2011-08-27 11:07:01 UTC
Pushed please test
Comment 6 Chris Nighswonger 2011-10-26 18:02:28 UTC
The fix for this bug was published in the 3.4.5 release. If you were the reporter of this bug, please take time to verify the fix and update the status of this bug report accordingly. If the bug is fixed to your satisfaction, please close this report.