Bug 6831 - Enhanced Workflow for adding analytical records
Summary: Enhanced Workflow for adding analytical records
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.8
Hardware: All All
: P2 enhancement (vote)
Assignee: Colin Campbell
QA Contact: Ian Walls
URL:
Keywords:
Depends on:
Blocks: 15955
  Show dependency treegraph
 
Reported: 2011-09-01 15:45 UTC by Colin Campbell
Modified: 2016-03-11 09:17 UTC (History)
7 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (6.08 KB, patch)
2011-09-08 13:55 UTC, Colin Campbell
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6831: Add ability to enter adding child record from parent (6.61 KB, patch)
2011-09-19 20:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6831: Add ability to enter adding child record from parent (7.72 KB, patch)
2012-03-11 21:22 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6831: Follow-up (5.05 KB, patch)
2012-03-11 21:22 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6831: Add ability to enter adding child record from parent (7.89 KB, patch)
2012-03-11 21:46 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 6831 follow-up: add support for UNIMARC and NORMARC (5.24 KB, patch)
2012-03-11 21:46 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Campbell 2011-09-01 15:45:25 UTC
Facility to make the workflow easier for entering analytical records In cataloguing after searching for the parent record the new tool bar option 'add child' takes you into the addbiblio screen but with the Host Item Tag already populated with data derived from the parent record
Comment 1 Savitra Sirohi 2011-09-08 10:43:29 UTC
If I understand this correctly, something similar is already available in bug 5528.

*** This bug has been marked as a duplicate of bug 5528 ***
Comment 2 Colin Campbell 2011-09-08 13:55:57 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2011-09-08 14:02:02 UTC
Hi Colin, this sounds really interesting! Hope to find time to take a closer look.
Comment 4 Colin Campbell 2011-09-08 14:24:33 UTC
Reopened and submitted patch. It was intended as a more minimal patch to ease the workflow and accuracy of adding the 773 tags building on the existing work on display of analytical links in 3.4.

We did look for the sponser at the bug 5528 development but it raised some issues with the import of existing analytical data and changes to existing practices. 

It would allow a add analytical option in standard Koha for those not wishing to turn on the full functionality in the 5528 development.

Only implemented for marc21 at the moment, patches for other formats welcome.
Comment 5 Katrin Fischer 2011-09-19 20:20:34 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2011-09-19 20:22:32 UTC
Works beautifully.
Comment 7 Ian Walls 2011-10-13 17:42:08 UTC
While this looks like a very promising additional workflow, without UNIMARC and NORMARC support, I cannot pass it through QA.  NORMARC treats Host Item Entry almost identically to MARC21, so a modification to the conditional can be made.  For UNIMARC, the 461 field is used.

a is 'author'
c is 'place of publication'
d is 'date of publication'
e is 'edition statement'
t is 'title'
u is 'URL'
x is 'ISBN/ISSN'

There is no corresponding 'w' field, at least in the English UNIMARC framework SQL which I've consulted to figure this out.
Comment 8 Katrin Fischer 2011-11-29 06:07:22 UTC
I am not sure I can make the necessary changes for UNIMARC. I don't know enough about it and I am not sure that not more work is needed to make it display properly. Would it be enough for now to make it controlled by a system preference? Or to make the links only show up for MARC21 setups?
Comment 9 Katrin Fischer 2011-12-18 20:19:59 UTC
I am still interested in this feature. 

Can someone say something about existing functionality for analytics in UNIMARC? I know the EasyAnalytics feature works with UNIMARC, but it uses item level information while this feature uses only fields on bib level and works without items.

Is there an interest to make this work for UNIMARC?
Comment 10 Katrin Fischer 2012-02-09 11:15:06 UTC
Can I get a comment from the QA team or UNIMARC users on this bug plz?
Comment 11 Chris Cormack 2012-02-22 22:19:15 UTC
This still works beautifully, but needs a follow up for UNIMARC .. I'd hate it to stay stalled for another 4 months waiting on that!
Comment 12 Chris Cormack 2012-02-22 22:20:14 UTC
Oh and fwiw, I agree, waiting for UNIMARC should not hold this up
Comment 13 Zeno Tajoli 2012-02-23 10:21:22 UTC
Hi this the subfiels for unimarc:

Tag: 461 field is used in children for link to father

a is 'author', all subs from tags 700 or 710 or 720
c is 'place of publication', from tag 210$a
d is 'date of publication' from tag 210$d
e is 'edition statement' from tag 205$a

t is 'title' from tag 200 or tag 500(uniform title), subfields $a,$b,$c,$e
with those trasformations:
$a(first) -> ''
$a(second and more) -> ' ; '
$b ->the value inside [ ] but often the signs are present in the data
$c -> '. '
$d -> '' The subfield is connect with ISDB sign ' = ' but Unimarc asks that those sign must be insde data
$e -> ' : '
This is the complete analisis for 'title' but I think that the implementation could be more simplex.

u is 'URL' from 856$u
x is 'ISSN' from tag 011$a
y is 'ISBN' from tag 010$a
0 is the value of 001 of father
The official document (very short):
http://archive.ifla.org/VI/8/unimarc-concise-bibliographic-format-2008.pdf
Pages 57-59

No problem to sign-off with only marc21 support
Comment 14 Zeno Tajoli 2012-02-29 11:49:57 UTC
Hi,

in the code added to addbiblio.pl
I see the new routine:
get_host_control_num (lines after 1073).
But I don't understand the use of this routine.
Comment 15 Colin Campbell 2012-03-01 16:42:17 UTC
Good spot Zeno the get_host_control_num routine is no longer used, its functionality is now part of prepare_host_field in C4::Biblio
Comment 16 Katrin Fischer 2012-03-11 21:22:08 UTC Comment hidden (obsolete)
Comment 17 Katrin Fischer 2012-03-11 21:22:20 UTC Comment hidden (obsolete)
Comment 18 Jared Camins-Esakov 2012-03-11 21:46:01 UTC
Created attachment 8165 [details] [review]
Bug 6831: Add ability to enter adding child record from parent

Simplifies the adding of analytical records and ensures that
the data populating the 773 tag is correct. From the host record
add child record is selected and create bib is entered to generate
a new record with host item tag populated from the parent

Caveat: currently prepare_host_field only returns a field for
MARC21. Values for UNIMARC and NORMARC can easily be added but
should be done by someone familar with those formats
and conventions

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
To test:
- create a new record
--> if you enter a value in 001 anaytics will use that in $w for linking later
--> if you set 000/LDR 19 - Multipart resource record level to 'a' there will
be a link from the parent record to the child record later
- save your record and go to the staff detail page
- in toolbar select 'New' > 'New child record'
- check field 773, 245 and 001 from the parent record should have been copied there
- check links between child and parent in staff

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Fixed conflicts in all 3 files.

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Works properly for MARC21, and follow-up adds support for NORMARC and UNIMARC.
Comment 19 Jared Camins-Esakov 2012-03-11 21:46:19 UTC
Created attachment 8166 [details] [review]
Bug 6831 follow-up: add support for UNIMARC and NORMARC

1) Removes unused subroutine get_host_control_num
2) Fixes small mistake, correct subfield for ISBN 020 is z
3) Checks system preference for correct marcflavour instead of
   assuming MARC21
4) Fixes MARC21 to not use author(), because it would also add
   fields like $w and $0 to 773$a
5) Fixes MARC21 to not use title(), but 245$a, because it would
   also add too many subfields.
6) Adds definitions for UNIMARC and includes NORMARC

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Works properly with all supported MARC flavours.
Comment 20 Ian Walls 2012-03-19 13:42:23 UTC
Thank you for providing the NORMARC and UNIMARC implementations.  These two patches together handle the support for both, as well as adding the Add Child Record button in the editor.  Marking as Passed QA.
Comment 21 Paul Poulain 2012-03-21 11:32:20 UTC
pushed, works like a charm in UNIMARC

test plan for unimarc:

* open a biblio record
* update the leader to say it's a serial
* the button "New > New child record" shoud appear
* click on it
* you'll reach a page with 461 field pre-filled with values from the parent record. isbn/biblionumber/title/... 461 field are filled

(note that Koha still handles only 4xx classical method, and not the 4xx subfields method -not sure of the translation term-)
Comment 22 Zeno Tajoli 2012-03-22 09:18:40 UTC
Documentation of the feature (correct comment #21 from Paul Poulain):

-- UNIMARC behavior --
A tag 461 field is inserted ina children record  for link to father records.

Data are inserted with Standard Subfield Technique.
For example: 
461  $05679988$tCiuntries of Europe

The Embedded Fields Technique is not supported.
Comment 23 Jared Camins-Esakov 2012-12-31 00:45:37 UTC
There have been no further reports of problems so I am marking this bug resolved.