Bug 6890 - Add reserves to modification logging
Summary: Add reserves to modification logging
Status: RESOLVED DUPLICATE of bug 14642
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: MJ Ray (software.coop)
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-20 21:09 UTC by Liz Rea
Modified: 2016-09-21 10:51 UTC (History)
9 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Bot Control: ---
When did the bot last check this: 2013-10-28 00:00:00
Who signed the patch off:
Text to go in the release notes:


Attachments
C4/Reserves.pm: log reservation actions catalogue/issuehistory.tt: link to viewlog for circulation log tools/viewlog.tt: add HOLD and UNHOLD actions, move results table nearer top tools/viewlog.pl: be more cautious in assuming info field in CIRCULATION is (18.00 KB, patch)
2012-04-06 11:17 UTC, MJ Ray (software.coop)
Details | Diff | Splinter Review
Bug 6890 - log reservation actions (17.97 KB, patch)
2012-12-14 00:01 UTC, MJ Ray (software.coop)
Details | Diff | Splinter Review
Bug 6890 - log reservation actions (11.84 KB, patch)
2013-10-05 01:40 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2011-09-20 21:09:44 UTC
It would be nice to be able to see which logged in user (or if the patron) deleted  or canceled a reserve.

This would be part of the "modification log," probably a new module, "reserves."
Comment 1 MJ Ray (software.coop) 2012-04-05 23:05:56 UTC
It would be nice to be able to see that a logged in user (or if the patron) placed or filled a reserve, wouldn't it?

At first glance this can't be done in master but I think I can see how to do it (key bit is to add UpdateStats calls to C4::Reserves).
Comment 2 MJ Ray (software.coop) 2012-04-06 11:17:17 UTC Comment hidden (obsolete)
Comment 3 MJ Ray (software.coop) 2012-04-06 11:18:50 UTC
There are many ways that this could be done: C4::Log, C4::Stats and the issues table to name but there.  Here is my implementation using C4::Log.
Comment 4 Liz Rea 2012-04-10 21:06:36 UTC
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/tools/viewlog.tt


:( I was looking forward to this too.
Comment 5 MJ Ray (software.coop) 2012-12-14 00:01:11 UTC Comment hidden (obsolete)
Comment 6 MJ Ray (software.coop) 2013-01-07 11:55:13 UTC
It blooming well did after I rebased on 2012-12-14 :-(
Comment 7 Chris Cormack 2013-10-05 01:40:21 UTC
Created attachment 21817 [details] [review]
Bug 6890 - log reservation actions

C4/Reserves.pm: log reservation actions
catalogue/issuehistory.tt: link to viewlog for circulation log
tools/viewlog.tt: add HOLD and UNHOLD actions, move results table nearer top
tools/viewlog.tt: rewrite to use loopro.module and to link better
members/readingrec.tt: link to circulation log for hold/unhold info

To test:
  1. place a few holds and release them somehow (cancel or issue);
  2. view the reading record of an affected borrower;
  3. click the link to the modification log and see the holds;
  4. click the link to an affected biblio;
  5. click to view its circulation history;
  6. click the link to the modification log and see the holds.
Comment 8 I'm just a bot 2013-10-28 06:24:40 UTC
Patch applied cleanly, go forth and signoff
Comment 9 Jonathan Druart 2014-01-27 11:04:24 UTC
The logs should be written only if a pref is set.
It is the usual way to log actions into Koha.

Marked as Failed QA.
Comment 10 MJ Ray (software.coop) 2014-02-14 17:24:38 UTC
In reply to comment 9:
> The logs should be written only if a pref is set.
> It is the usual way to log actions into Koha.

What pref should be set?

What coding guideline sets this out?
Comment 11 Jonathan Druart 2014-02-17 12:54:35 UTC
(In reply to MJ Ray (software.coop) from comment #10)
> In reply to comment 9:
> > The logs should be written only if a pref is set.
> > It is the usual way to log actions into Koha.
> 
> What pref should be set?
> 
> What coding guideline sets this out?

Hello MJ,
You can have a look at admin/preferences.pl?tab=logs and at the result of the following command:
   git grep logaction

The action_logs table is filled depending on syspref values, so I suppose you should do the same.
If you disagree, you can ask another QAer to have a look.
Comment 12 Tomás Cohen Arazi 2016-09-21 10:51:20 UTC

*** This bug has been marked as a duplicate of bug 14642 ***