Bug 6902 - Add integration for EBSCO's Novelist Select service
Summary: Add integration for EBSCO's Novelist Select service
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.6
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 11606
  Show dependency treegraph
 
Reported: 2011-09-21 19:13 UTC by Ian Walls
Modified: 2014-01-24 13:52 UTC (History)
1 user (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (functionality) (7.01 KB, patch)
2011-09-22 20:27 UTC, Ian Walls
Details | Diff | Splinter Review
Proposed patch (DB changes) (3.91 KB, patch)
2011-09-22 20:28 UTC, Ian Walls
Details | Diff | Splinter Review
Signed-off patch (7.10 KB, patch)
2011-10-07 15:23 UTC, Owen Leonard
Details | Diff | Splinter Review
Signed-off patch (4.18 KB, patch)
2011-10-07 15:28 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2011-09-21 19:13:45 UTC
Add support for Novelist Select content to be displayed in the OPAC

Add a group of preferences to the Enhanced Content tab for Novelist
        NovelistSelectEnabled
        NovelistSelectProfile
        NovelistSelectPassword
        NovelistSelectView

Integrate Novelist content in to the bib detail page in the OPAC (in NovelistSelectEnabled is set to "enabled")

If NovelistSelectView indicates “in a tab” (the default setting), then a new tab shall be added along side the holdings, title notes, comments, etc.

If NovelistSelectView indicates “beneath the Holdings table”, the
content shall appear below the holdings table.

If NovelistSelectView indicates “above the Holdings table”, the
content shall appear above the holdings table.

If NovelistSelectView indicates “under Save Record”, the
content shall appear below the Save Record div, on the right of the screen.

The precise content, HTML and styling will be handled by EBSCO as part of the Novelist Select service.
Comment 1 Ian Walls 2011-09-22 20:27:50 UTC Comment hidden (obsolete)
Comment 2 Ian Walls 2011-09-22 20:28:35 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2011-10-07 15:23:19 UTC
Created attachment 5776 [details] [review]
Signed-off patch
Comment 4 Owen Leonard 2011-10-07 15:28:15 UTC
Created attachment 5777 [details] [review]
Signed-off patch

These patches tested fine for me. The changes to the code are minimal, since the Novelist data, like LibraryThing data, is pulled in via JavaScript. A couple of comments, neither of which would prevent this from going forward:

The option to put the content in the right-hand sidebar doesn't really work well because of the quantity of content. It's too squeezed. Since the position of the content is controlled by a system preference, this is easily avoided.

A good follow-up might be to add <noscript> text following the model of the LibraryThing content. Otherwise users with JS disabled will see the Novelist heading but no content and no explanation.
Comment 5 Ian Walls 2011-10-07 16:42:55 UTC
Chris, as this patch introduces new strings, I'd like to mark Passed QA now.  This is purely self-interest, however, and I would prefer another set of eyes on it.  It's largely a template-only change, and turning off the feature leave the OPAC exactly as it is now, but I just feel shady about pushing this through when I'm the author.
Comment 6 Chris Cormack 2011-10-11 02:30:16 UTC
Have tested this, it introduces no regressions and is a nice feature, pushing
Comment 7 Jared Camins-Esakov 2012-05-23 12:45:59 UTC
As far as I can tell, this is working properly. Closing.