Bug 6911 - Log viewer should remember search terms
Summary: Log viewer should remember search terms
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 11600 (view as bug list)
Depends on:
Blocks: 10355 13889
  Show dependency treegraph
 
Reported: 2011-09-23 10:48 UTC by Katrin Fischer
Modified: 2015-12-03 22:02 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 6911: Remember search terms in the log viewer tool (6.70 KB, patch)
2015-03-27 09:06 UTC, Jonathan Druart
Details | Diff | Splinter Review
[Signed-off] Bug 6911: Remember search terms in the log viewer tool (6.87 KB, patch)
2015-03-27 14:15 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 6911: Remember search terms in the log viewer tool (6.92 KB, patch)
2015-04-05 20:38 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6911: (follow-up) Reintroduce few lines to avoid regression (1017 bytes, patch)
2015-04-16 14:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 6911: (follow-up) Reintroduce few lines to avoid regression (1.06 KB, patch)
2015-04-16 15:09 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-09-23 10:48:28 UTC
The log viewer's search form will go back to the default values after submit.
There is no way to see what you have searched for after submitting, which is quite annoying.
Comment 1 Jonathan Druart 2015-03-27 09:06:46 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2015-03-27 14:15:02 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2015-04-05 20:38:10 UTC
Created attachment 37510 [details] [review]
[PASSED QA] Bug 6911: Remember search terms in the log viewer tool

The modules and actions selected by the user are now selected when a
log search is done.
Note that this patch also add the multiple attribute to the actions
select in order to add the ability to select several actions.
The code to do that already existed.

Test plan:
1/ Go on the log viewer tool (tools/viewlog.pl)
2/ Launch a search with modules and actions selected.
3/ Confirm that the values you have selected is still selected after the
search.

Patch works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Katrin Fischer 2015-04-05 20:38:32 UTC
Thx Jonathan!
Comment 5 Tomás Cohen Arazi 2015-04-13 17:45:56 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 6 Jonathan Druart 2015-04-16 14:30:10 UTC
This patch removes too many lines and introduced a bug.

If you come from the biblio detail page and click on "modification log", you should get the circ menu, not the tools menu.
Comment 7 Jonathan Druart 2015-04-16 14:32:43 UTC Comment hidden (obsolete)
Comment 8 Jonathan Druart 2015-04-16 14:33:31 UTC
Quick patch, easy to test. Could I get a quick QA look please?
Comment 9 Tomás Cohen Arazi 2015-04-16 15:09:20 UTC
Created attachment 37968 [details] [review]
[PASSED QA] Bug 6911: (follow-up) Reintroduce few lines to avoid regression

If you come from the biblio detail page and click on "modification log",
you should get the circ menu, not the tools menu.

Test plan:
1/ Go on a biblio detail page
2/ Click on the "modification log" tab
3/ You should get the modification log page with the circ menu.

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 10 Tomás Cohen Arazi 2015-04-16 17:22:24 UTC
QA followup pushed.

Thanks Jonathan!
Comment 11 Chris Cormack 2015-04-20 10:33:24 UTC
Template changes, held for 3.18.7
Comment 12 Jonathan Druart 2015-04-24 11:08:42 UTC
*** Bug 11600 has been marked as a duplicate of this bug. ***
Comment 13 Chris Cormack 2015-04-29 21:37:42 UTC
Applied on 3.18.x will be in 3.18.7