Bug 6920 - deleting bibs messes with budgets
Summary: deleting bibs messes with budgets
Status: RESOLVED DUPLICATE of bug 10758
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Henri-Damien LAURENT
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 8149
  Show dependency treegraph
 
Reported: 2011-09-26 13:55 UTC by Nicole C. Engard
Modified: 2013-09-18 07:54 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-09-26 13:55:03 UTC
Example from a library I talked to today:

An order was placed for an item using a brief record (with ISBN). While waiting for the order to arrive a fuller record was imported from OCLC using the ISBN match, but the match was not found so duplicates were created.  The library deleted the brief record because the OCLC one was fuller and this left a hole in the order and screwed up the accounting.  The next time they chose to merge the OCLC and brief record together but the same thing happened because the bib number from the brief record was lost in the merge.

--------------

All libraries are going to delete bib records at some point and if those records were created using acquisitions then the budgeting is going to be inaccurate.  It will also leave holes on baskets when viewing them with links to records that do not exist. We need a way to keep the link between acq and the catalog without allowing changing in cataloging to mess up orders in acq.  

Another solution is to update the merge tool to look at the acq tables and change the bib number if records are merged - but that's secondary to the bigger problem of the bib being able to cause so many problems when deleted.
Comment 1 mathieu saby 2013-09-18 07:54:29 UTC
I think it will be fixed by Bug 10758 ( Show bibliographic information of deleted records in acquisitions) and Bug 9780 ( Deleting a record suppress bibliographic info in orders using that record)

M. Saby

*** This bug has been marked as a duplicate of bug 10758 ***