Bug 6945 - Add a link to show a MARC preview in the normal view
Summary: Add a link to show a MARC preview in the normal view
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.12
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Maxime Pelletier
QA Contact: Mason James
URL:
Whiteboard:
Keywords:
: 2134 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-29 21:04 UTC by Maxime Pelletier
Modified: 2013-12-05 20:05 UTC (History)
6 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Screenshot showing the new link MARC Preview (46.21 KB, image/png)
2011-09-29 21:04 UTC, Maxime Pelletier
Details
patch (1.27 KB, patch)
2011-09-29 21:05 UTC, Maxime Pelletier
Details | Diff | Splinter Review
[SIGNED-OFF] Add a link to show a MARC preview in the normal view of the detail (1.39 KB, patch)
2011-09-30 12:06 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Follow-up fix (1.45 KB, patch)
2011-09-30 13:11 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Follow-up fix for Bug 6945, Add a link to show a MARC preview in the normal view (1.49 KB, patch)
2011-09-30 13:44 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Follow-up : Add an id on the "Marc Preview" <span> (1.56 KB, patch)
2011-10-21 20:12 UTC, Frédérick Capovilla
Details | Diff | Splinter Review
Follow-up: Add preview to XSLT view, add unique id to containing element in both views (2.04 KB, patch)
2012-08-22 20:14 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Add a link to show a MARC preview in the normal view of the detail (1.39 KB, patch)
2012-08-23 13:02 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6945 [FOLLOW-UP] Add a link to show a MARC preview in the normal view (2.08 KB, patch)
2012-08-23 13:02 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 6945 counter patch adding link in the cat-toolbar (1.18 KB, patch)
2012-10-05 09:42 UTC, Paul Poulain
Details | Diff | Splinter Review
[SIGNED-OFF] Add a link to show a MARC preview in the normal view of the detail (1.41 KB, patch)
2012-11-05 19:30 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6945 [FOLLOW-UP] Add a link to show a MARC preview in the normal view (2.09 KB, patch)
2012-11-05 19:30 UTC, Owen Leonard
Details | Diff | Splinter Review
Add a link to show a MARC preview in the normal view of the detail (1.37 KB, patch)
2012-11-29 17:07 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 6945 [FOLLOW-UP] Add a link to show a MARC preview in the normal view (2.09 KB, patch)
2012-11-29 17:07 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime Pelletier 2011-09-29 21:04:35 UTC
Created attachment 5651 [details]
Screenshot showing the new link MARC Preview

Adds a link MARC Preview to show the MARC in a greybox in the Normal view of catalogue/detail.pl.

Sponsored by our client http://www.ccsr.qc.ca/
Comment 1 Maxime Pelletier 2011-09-29 21:05:04 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2011-09-30 12:06:27 UTC Comment hidden (obsolete)
Comment 3 Nicole C. Engard 2011-09-30 12:07:00 UTC
I have signed off on this simple patch, but you might consider editing the XSLT stylesheets with this link as well.

Nicole
Comment 4 Owen Leonard 2011-09-30 13:11:16 UTC Comment hidden (obsolete)
Comment 5 Nicole C. Engard 2011-09-30 13:44:00 UTC Comment hidden (obsolete)
Comment 6 Ian Walls 2011-10-18 15:08:01 UTC
This feature is not going to be universally desirable to all libraries; I'd prefer a unique ID in one of the HTML elements so that JQuery can hide the feature at the library's discretion.

This is not reason enough to block QA, however.  Marking as Passed, with a request for followup.
Comment 7 Frédérick Capovilla 2011-10-21 20:12:46 UTC Comment hidden (obsolete)
Comment 8 Owen Leonard 2011-10-24 17:15:34 UTC
*** Bug 2134 has been marked as a duplicate of this bug. ***
Comment 9 Paul Poulain 2011-11-06 10:29:53 UTC
For consistency reasons i'll reject this patch. Here is what I get on my screen :
====================================
Massacre (The) éô ï

By 50 Cent

   * Additional Authors:
      by  50 Cent
   * Published by: Shady/Aftermath , 2006
   * Description: 1 d.c.
   * MARC Preview: Show
===================================
(that is what is also in the screenshot submitted by Maxime)

The "MARC Preview" is not related to the biblio content, so the link should not be here. It should be either on the action button (on the right of "place hold" for example) or on the left tab.

You can also do exactly the same thing just using XSLT, and I think it's the best way to do it: just activate XSLT and add a XSLT link to the MARC preview after the description. Thus, no need to add code to Koha
Comment 10 Paul Poulain 2011-11-06 10:31:54 UTC
unless you're very good arguments, I think this bug must be RESO/INVALID.
Comment 11 Nicole C. Engard 2011-11-06 13:06:00 UTC
I have a very good reason.  Professional catalogers (like me) hate the way Koha shows MARC records.  It's cluttered, shows way more info than I need and makes my life difficult.  In the OPAC there is a way to see the plain MARC record and patrons could care less - but in the staff client there isn't an option to see this which seems just wrong.  

I don't care where the link is moved to, but there must be a link to see the real MARC record in the staff client from the bib record instead of just the labeled and slightly differently labeled views.
Comment 12 Paul Poulain 2011-11-06 14:39:54 UTC
OK, seen comment 11, I won't try to go against your needs, but I'm still thinking:
* it should not be in the biblio
* if one really want it in the biblio, then just add it into the XSLT and activate XSLT

So an improved/updated patch is still welcomed (and I won't close this bug until we've found a consensus/solution)
Comment 13 Nicole C. Engard 2011-11-06 15:08:37 UTC
I'm not sure I understand what you mean about it not being in the biblio.  Do you mean it shouldn't be mixed in with the info from the bib (like the title, author, subjects, etc)?  If so, I'm okay with that - there is a MARC tab on the left and a labeled MARC tab over there too.  So I'm okay with adding another tab for MARC - not sure what to call it, because right now the MARC and the Labeled MARC tabs both show Labeled MARC just slightly different .. hopefully Maxime has some ideas.

Nicole
Comment 14 Paul Poulain 2011-11-06 15:39:37 UTC
(In reply to comment #13)
> Do
> you mean it shouldn't be mixed in with the info from the bib (like the title,
> author, subjects, etc)? 
yes, exactly.

> If so, I'm okay with that
Perfect

> - there is a MARC tab on the
> left and a labeled MARC tab over there too.  So I'm okay with adding another
> tab for MARC - not sure what to call it, because right now the MARC and the
> Labeled MARC tabs both show Labeled MARC just slightly different .. hopefully
> Maxime has some ideas.
Another option would be to put it in a button on the right of "Print" and "Place hold". I'm not sure which is the best option: it would be more logical to have it on the left, where we already have "Normal" "MARC", "labelled MARC", "ISBD" and "Items". But that would add a 6th view, and put "Hold" and "Subscriptions" (if applicable) very low.

Adding Owen to this discussion, Owen, if you have a suggestion, it will be welcomed !
A small idea : remove the "Holds" tab, that points exactly to the same location that "Place hold" on the top-right. I remember some libraries being a little bit confused to have exactly the same thing in 2 places. Maybe it's time to remove the tab, and use the place for the "marc preview" !
Comment 15 Owen Leonard 2011-11-06 18:10:45 UTC
(In reply to comment #14)
.
> Another option would be to put it in a button on the right of "Print" and
> "Place hold"

Buttons are for actions, tabs are for views. That's why we have both a button and a tab for holds. A person might want to view holds or they might want to add a hold.

That said, I don't have any problem with this patch as-is. If we figure out a way to do it better later we can fix it.
Comment 16 Maxime Pelletier 2012-03-05 23:12:18 UTC
Is my patch still a problem after the comments by oleonard and nengard ? I think the id in the followup patch makes it easy to hide if it's not wanted.
Let me know if this needs any more work.
Comment 17 Jared Camins-Esakov 2012-03-17 10:20:19 UTC
Could you clarify the status of this bug? If this were rebased, and the follow-up signed off, would that be sufficient, or are there additional changes required?
Comment 18 Owen Leonard 2012-04-02 19:50:20 UTC
I'll add my sign-off once this is rebased.
Comment 19 Owen Leonard 2012-08-22 20:14:53 UTC Comment hidden (obsolete)
Comment 20 Nicole C. Engard 2012-08-23 13:02:22 UTC Comment hidden (obsolete)
Comment 21 Nicole C. Engard 2012-08-23 13:02:52 UTC Comment hidden (obsolete)
Comment 22 Mason James 2012-09-16 13:02:10 UTC
> Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>

patches looks good, passing QA…

$ koha-qa.pl  -c 2

testing 2 commit(s) (applied to commit b592d34)
 * 86b0a36 Bug 6945 [FOLLOW-UP] Add a link to show a MARC preview in the nor
      koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt

 * 1227251 Add a link to show a MARC preview in the normal view of the detai
      koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt

* koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt              OK
Comment 23 Paul Poulain 2012-09-18 20:17:48 UTC
Trying to apply patch & follow-up, I get a git problem with the 2nd patch:
Applying: Bug 6945 [FOLLOW-UP] Add a link to show a MARC preview in the normal view
fatal: sha1 information is lacking or useless (koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Comment 24 Owen Leonard 2012-10-02 16:08:46 UTC
Paul could you try again? I used git bz to apply these patches today and while the second one required an automatic 3-way merge it did finish successfully.
Comment 25 Paul Poulain 2012-10-05 09:42:32 UTC Comment hidden (obsolete)
Comment 26 Paul Poulain 2012-10-05 09:44:17 UTC
(In reply to comment #24)
> Paul could you try again? I used git bz to apply these patches today and
> while the second one required an automatic 3-way merge it did finish
> successfully.

I tried again, and it does not work again.


I've submitted a counter-patch to explain what I would prefer: the patch add a YUI button to the toolbar. It works except that the page is not displayed in a small window, but in the main one. I couldn't find how to have the             rel="gb_page_center[600,500]"
Comment 27 Jared Camins-Esakov 2012-10-06 04:14:16 UTC
Changing target version so this bug report will show up in the list of 3.12-targeted features and doesn't get lost in the shuffle during feature freeze.
Comment 28 Jared Camins-Esakov 2012-11-05 16:56:25 UTC
Owen,

Could you please rebase *both* patches and reattach them? That should resolve the "sha1 information is lacking or useless" message that I get.

Also, what is your thought on Paul's counter-patch?
Comment 29 Owen Leonard 2012-11-05 19:30:01 UTC Comment hidden (obsolete)
Comment 30 Owen Leonard 2012-11-05 19:30:55 UTC Comment hidden (obsolete)
Comment 31 Owen Leonard 2012-11-05 19:39:40 UTC
I feel pretty strongly that putting the link in the toolbar is not the right solution. This MARC preview link doesn't fit with views in the left-hand sidebar menu because it doesn't take you to a new page. It doesn't fit with the actions in the toolbar because it doesn't "do" something (like edit the record or put a hold on the record).

I can't give a good argument for putting the link where it is in these patches other than to say that it's better than the other options.
Comment 32 Nicole C. Engard 2012-11-09 15:54:48 UTC
I agree with Owen on this.
Comment 33 Paul Poulain 2012-11-29 17:03:19 UTC
Comment on attachment 12695 [details] [review]
Bug 6945 counter patch adding link in the cat-toolbar

counter-patch does not please owen & nicole, removing it by obsoleting
Comment 34 Paul Poulain 2012-11-29 17:07:40 UTC
Created attachment 13780 [details] [review]
Add a link to show a MARC preview in the normal view of the detail

http://bugs.koha-community.org/show_bug.cgi?id=6945
Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Comment 35 Paul Poulain 2012-11-29 17:07:45 UTC
Created attachment 13781 [details] [review]
Bug 6945 [FOLLOW-UP] Add a link to show a MARC preview in the normal view

Adding the same MARC preview link to the section of the template
which is displayed when XSLT is on.

This revision also adds a unique id to the surrounding element in the
normal and XSLT versions.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 36 Paul Poulain 2012-11-29 17:15:11 UTC
QA comment:
 * despite I don't like the place where the link is placed, I QA this patch because I agree with Nicole & Owen it's an interesting link for librarians
 * tiny patch

passes QA
Comment 37 Jared Camins-Esakov 2012-11-30 12:39:14 UTC
This patch has been pushed to master.