Bug 6953 - Value builder for NORMARC 007 does not show further options
Summary: Value builder for NORMARC 007 does not show further options
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Magnus Enger
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-01 15:41 UTC by Magnus Enger
Modified: 2013-12-05 19:53 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.21 KB, patch)
2011-10-01 15:50 UTC, Magnus Enger
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2011-10-01 15:41:52 UTC
The value builder for NORMARC field 007 refuses to display further options when something is selected from the initial dropdown. This is caused by this commit forgetting to include the trailing "\" for multiline JavaScript: http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=5d4d5989d0356153a6780b16650b2c43ed6b9e8b
Comment 1 Magnus Enger 2011-10-01 15:50:30 UTC
Created attachment 5672 [details] [review]
Proposed patch

To test: 

- Start adding a new MARC record in the default framework
- Click on the value builder for 007
- Copy the URL of the value builder
- Paste the URL into a new window
- Change marc21 into normarc, so you get something like /cgi-bin/koha/cataloguing/plugin_launcher.pl?plugin_name=normarc_field_007.pl&index=tag_007_subfield_00_813528_971811&result=
- Check that selecting something from the initial dropdown displays more options specific to the material type you chose
Comment 2 Ian Walls 2011-10-06 12:43:58 UTC
Simple, one-line, template only patch to meet agreed upon standards.  Marking as signed off and Passed QA
Comment 3 Chris Cormack 2011-10-06 23:07:43 UTC
Pushed, please test
Comment 4 Magnus Enger 2012-04-27 14:18:18 UTC
Works in 3.8.