Bug 6959 - Can't import record via Z39.50 from MARC edit page
Summary: Can't import record via Z39.50 from MARC edit page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-03 13:16 UTC by Nicole C. Engard
Modified: 2012-10-25 23:10 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Proposed Patch (1.36 KB, patch)
2011-10-04 17:26 UTC, Ian Walls
Details | Diff | Splinter Review
Signed-off patch (1.46 KB, patch)
2011-10-04 18:31 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-10-03 13:16:35 UTC
Importing a record via Z39.50 on the MARC edit page (addbiblio.pl) doesn't
work, whether you're importing into a blank record or into an existing record.
After clicking the "import" link the MARC editor is reloaded but all that
displays is the toolbar. The editor is completely gone.
Comment 1 Owen Leonard 2011-10-04 16:44:03 UTC
I've noticed auto-fill of the leader is now broken too. git bisect traces this
problem back to the fix for Bug 6576 (changing framework while cataloging
looses data, c453a45f384ce87a8af4ab9339fb877b11a79105). I'm wondering now if
that commit is the cause of this problem as well.
Comment 2 Ian Walls 2011-10-04 17:26:24 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2011-10-04 18:31:55 UTC
Created attachment 5705 [details] [review]
Signed-off patch

Before applying the patch: Could not load a record into the MARC editor from Z39.50 search results, neither into a blank record nor an existing record. After applying the patch, both operations work.
Comment 4 Ian Walls 2011-10-07 14:18:06 UTC
Template only change, adjusts name to match update.  Marking as Passed QA unless anyone has any objections.
Comment 5 Chris Cormack 2011-10-08 06:59:50 UTC
Pushed, please test