Bug 6985 - Hide "kw,wrdl:" from Search Results
Summary: Hide "kw,wrdl:" from Search Results
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Liz Rea
QA Contact: Bugs List
URL:
Keywords:
: 7209 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-06 20:00 UTC by Thatcher Rea
Modified: 2013-12-05 19:59 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Screenshot of Search Results (32 bytes, text/plain)
2011-10-06 20:12 UTC, Thatcher Rea
Details
bug 6985 - remove kw,wrdl from the search results (1.71 KB, patch)
2012-01-25 20:43 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6985 - remove kw,wrdl from the search results (1.78 KB, patch)
2012-01-28 15:11 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 6985 - remove kw,wrdl from the search results (1.65 KB, patch)
2012-02-03 15:32 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6985 - remove kw,wrdl from the search results (2.68 KB, patch)
2012-02-03 16:30 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 6985 - remove kw,wrdl from the search results (2.71 KB, patch)
2012-02-06 16:11 UTC, Adrien SAURAT
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Thatcher Rea 2011-10-06 20:00:23 UTC
Hide the search string "kw,wrdl:" (and it's variants) from the Search Results.
Comment 1 Thatcher Rea 2011-10-06 20:12:50 UTC
Created attachment 5752 [details]
Screenshot of Search Results
Comment 2 Thatcher Rea 2011-10-06 20:13:28 UTC
Screenshot of Search Results:

http://screencast.com/t/kolmH6ha
Comment 3 Liz Rea 2012-01-25 16:52:24 UTC
There are a couple of ways this could be fixed:

1. Don't show it at all in the OPAC
2. Change the text to something else "Your search returned"
3. Use local jquery to do either of the above.

Does this need to be a systemic change, or can we handle it with jquery?
Comment 4 Katrin Fischer 2012-01-25 17:08:29 UTC
+1

I think it's quite hard to do with jQuery right now, because the part is not formatted nicely. If people want to keep it, some reformatting and adding of ids would be good.

I think I would prefer a global change here. "Your search returned XX results."
Comment 5 Liz Rea 2012-01-25 20:43:06 UTC Comment hidden (obsolete)
Comment 6 Gaetan Boisson 2012-01-27 16:22:38 UTC
These strings also appear in a patron's search history. Where something more explicit would be better, imho.
Comment 7 Jared Camins-Esakov 2012-01-28 15:11:04 UTC Comment hidden (obsolete)
Comment 8 Adrien SAURAT 2012-02-03 14:53:37 UTC
This works fine when we have a result, but if there is none we do still have a variant of "kw,wrdl" appearing.

Example:
No results match your search for “kw,wrdl: tsfdfs branch:Bibliothèque de Benquet” in Catalog.

Also, like mentionned earlier by Gaetan, the search history displays lines like:
Date	Search	Results
03/02/2012 15:49:18 	au,wrdl: test2 	0
03/02/2012 15:49:04 	se,wrdl: test 	0
03/02/2012 15:48:51 	nb: test 	0
03/02/2012 15:47:09 	kw,wrdl: tsfdfs 	0
03/02/2012 15:47:01 	kw,wrdl: tsfdfs 	0
It's a little bit out of this bug scope, though (but shares the same goal of avoiding strange strings displayed to users).
Comment 9 Liz Rea 2012-02-03 15:16:31 UTC
good point. Two shakes and I'll get the "no results" on there too.
Comment 10 Liz Rea 2012-02-03 15:32:38 UTC Comment hidden (obsolete)
Comment 11 Adrien SAURAT 2012-02-03 15:58:12 UTC
Oh, looks like this patch only include the last modification, but the 1st was marked as obsolete.
I did install this one and now it works with no result but not anymore when I have results.

Could you make a patch merging the two modifications, please?
Thanks.
Comment 12 Liz Rea 2012-02-03 16:30:59 UTC Comment hidden (obsolete)
Comment 13 Gaetan Boisson 2012-02-03 17:00:53 UTC
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7497

Created to address the search history problem.
Comment 14 Adrien SAURAT 2012-02-06 16:11:57 UTC
Created attachment 7468 [details] [review]
Bug 6985 - remove kw,wrdl from the search results

Bug 6985 - remove kw,wrdl from the search results
Signed off.
Comment 15 Katrin Fischer 2012-02-08 16:08:24 UTC
*** Bug 7209 has been marked as a duplicate of this bug. ***
Comment 16 Ian Walls 2012-02-16 17:15:19 UTC
Removes this 'debugging' kind of information from the OPAC in a template-only change.  Marking as Passed QA.
Comment 17 Jared Camins-Esakov 2012-05-23 13:02:35 UTC
This fix was included in the 3.6.x branch prior to 3.6.4.