Bug 7026 - Web installer does not switch language
Summary: Web installer does not switch language
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Target Milestone: Oldversions
Assignee: Henri-Damien LAURENT
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on: 5660
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-13 20:49 UTC by Katrin Fischer
Modified: 2018-12-16 19:34 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.31 KB, patch)
2011-10-17 06:20 UTC, Frédéric Demians
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7026 Web installer does not switch language (1.74 KB, patch)
2011-10-18 05:54 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 7026 Web installer does not switch language (1.78 KB, patch)
2011-10-18 15:25 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-10-13 20:49:39 UTC
Language installer should switch to template files of language selected in first step. It used to do that, but the feature seems to be broken now. Web installer remains English after selecting a different language.

To reproduce:

- make sure your database is empty
- run 'perl translate install <some language>
- access web installer
- select language other then en on the first page
> templates should change to translated templates
Comment 1 Frédéric Demians 2011-10-17 06:17:06 UTC
I confirm the bug. It has been introduced by patch for bug 5660. A test is done on a system preference to avoid bug 5660. It works for update but it can't work for a fresh install which hasn't a populated DB at first. I will propose a patch. But someone should check it doesn't introduce back bug 5660.
Comment 2 Frédéric Demians 2011-10-17 06:20:13 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2011-10-18 05:54:46 UTC Comment hidden (obsolete)
Comment 4 Paul Poulain 2011-10-18 15:25:44 UTC
Created attachment 5957 [details] [review]
Bug 7026 Web installer does not switch language

Language installer should switch to template files of language selected in
first step. It used to do that, but the feature seems to be broken now. Web
installer remains English after selecting a different language.

To reproduce:

- make sure your database is empty
- run 'perl translate install <some language>
- access web installer
- select language other then en on the first page

=> templates should change to translated templates

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>

Test plan provided works, correct language and sample files are selected.

In a second test I deleted the staff templates for de-DE and repeated
the steps. de-DE is not offered in the language selection of the web installer
now, but does appear in the opaclanguages list after running the web installer.
(Bug 5660)

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 5 Paul Poulain 2011-10-18 15:26:58 UTC
QA comment :
  * good description & test plan
  * nasty bug for non english setups, solved by this patch
  * clean code

passed QA (upgrading severity to CRI)
Comment 6 Chris Cormack 2011-10-19 02:47:50 UTC
Pushed, please test