Bug 7140 - Add item type description on the catalogue search and detail screens
Summary: Add item type description on the catalogue search and detail screens
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.6
Hardware: All All
: P3 enhancement (vote)
Assignee: Srdjan Jankovic
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-02 05:24 UTC by Srdjan Jankovic
Modified: 2013-12-05 19:59 UTC (History)
5 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
patch (14.20 KB, patch)
2011-11-02 06:51 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Signed-off patch (14.30 KB, patch)
2011-11-02 13:54 UTC, Owen Leonard
Details | Diff | Splinter Review
Print screen 1 (171.85 KB, image/pjpeg)
2011-11-28 09:02 UTC, Marcel de Rooy
Details
Print screen 2 (172.92 KB, image/pjpeg)
2011-11-28 09:02 UTC, Marcel de Rooy
Details
patch (14.13 KB, patch)
2012-01-27 04:03 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Bug 7140: Added item description to complement icon to search result and biblio detail pages (14.37 KB, patch)
2012-02-07 14:18 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Srdjan Jankovic 2011-11-02 05:24:16 UTC
Similar to opac-detail. Facilitates page text search
Comment 1 Srdjan Jankovic 2011-11-02 06:51:46 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2011-11-02 13:54:44 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2011-11-28 09:02:00 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2011-11-28 09:02:53 UTC Comment hidden (obsolete)
Comment 5 Marcel de Rooy 2011-11-28 09:08:48 UTC
QA Comment:
Thanks for sending your patches, but the description of this bug report is minimal and test plan is missing. It would be helpful to include more information. This will help people testing and signing off as well as QA.

Please look at the two print screens I attached (with and without your patch). With your patch two item type descriptions are listed. This probably occurs when a icon is not found and the alternate text is displayed.
Comment 6 Srdjan Jankovic 2011-11-29 00:00:54 UTC
It is a fairly small change so I did not describe it in too many details:

OPAC catalog search results screen have item type displayed as text as well as the icon. This is for the reason being able to use browser text search on the item type. We wanted to replicate that behaviour on the intranet interface, in catalog search and biblio details screens.

How to test:
Check that item type text is displayed at the end of item type description on catalogue/search.pl results screen and catalogue/detail.pl items.

Doubled description is due to the missing icon. You can try searching on "Books", missing icons text should be skipped. If it is not, please check the page source.
Comment 7 Marcel de Rooy 2011-11-30 13:20:50 UTC
Thanks for responding and providing more info.
You are right about the double itemtype. It is not related to your patch; it is just a strange thing on several places in Koha to show it twice if noItemTypeImages is set or the imageurl is empty. In my opinion listing it twice is just a bug. But that is another bug report.

I would like to add to your comment that results depend on the value of pref item-level_itypes. I have two points on your patch now:

Search Results:
if item-level_itypes==item, then the itemtype (+icon) is already in the column Location (per item) 
if item-level_itypes==biblio, then the itemtype (+icon) is already in the column Results
my conclusion would be: itemtype is not needed additionally here (redundant)

Catalogue Details/Items tab: 
if item-level_itypes==biblio, then the item type is listed with the biblio on top
if item-level_itypes==item, then the item type is listed per item
Your patch apparently does not really change anything here. (But it would catch the situation mentioned above!) It merely rearranges the tests on noItemTypeImages and imageurl.
Looking further, I think that the moredetail script (for the Items tab) should fill imageurl for items, but it does not. The template uses that empty variable! So it never shows an icon. If you change the code here, please resolve that bug too.

After those two points, I am wondering if the changes in Search.pm are necessary. Did not further look into that. Could you explain why they are necessary?

I agree with you that this is a lot of text for a small patch ;)
Comment 8 Marcel de Rooy 2011-11-30 15:34:49 UTC
Additional comment:
Sorry for the confusion. I was looking for catalogue/detail items at catalogue moredetail items.
The noItemTypeImages variable is already filled in Auth.pm, so that is not a bug. Moredetail simply never shows the icon.
Your patch adds the description at detail, so that is okay.

Remains the first point of search results and the question whether changes in Search.pm are needed?

So, even more text.. :-)
Comment 9 Srdjan Jankovic 2012-01-06 03:26:13 UTC
Search Results: I cannot see where the item type description gets duplicated. My intention was only to make sure it gets displayed regardless of whether the icon is present or not. Can you please point out/supply a screenshot of duplicated item type descriptions
Comment 10 Marcel de Rooy 2012-01-09 08:25:16 UTC
(In reply to comment #9)
> Search Results: I cannot see where the item type description gets duplicated.
> My intention was only to make sure it gets displayed regardless of whether the
> icon is present or not. Can you please point out/supply a screenshot of
> duplicated item type descriptions
Please see comment 7 (not relevant for this report).

Remains the first point of search results and the question whether changes in
Search.pm are needed?
Comment 11 Srdjan Jankovic 2012-01-27 04:03:54 UTC Comment hidden (obsolete)
Comment 12 Jared Camins-Esakov 2012-02-07 14:18:48 UTC
Created attachment 7475 [details] [review]
Bug 7140: Added item description to complement icon to search result and biblio detail pages

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
This seems like a very big improvement, especially for people using screen
readers. I agree that the change to C4::Search is required.
Comment 13 Paul Poulain 2012-02-20 20:33:48 UTC
Trying to QA this patch, and there's something I don't understand.

The display of the img is:
                            <img src="[% itemloo.imageurl %]" alt="[% itemloo.description %]" title="[% itemloo.description %]" />

BEFORE the patch.
isn't alt related to dealing with the case of screen readers, displaying the "alt" instead of the image ?

I tried my test database (that is item-level_itype=biblio), and I see the "Disque compact" text instead of the image when I run lynx.
Comment 14 Srdjan Jankovic 2012-02-21 04:19:38 UTC
Our clients asked us for this, so they must have a reason. Do you want me to ask them which particular reader/process they are using?
Comment 15 Paul Poulain 2012-02-27 15:22:51 UTC
(In reply to comment #14)
> Our clients asked us for this, so they must have a reason. Do you want me to
> ask them which particular reader/process they are using?

yes, please. And more than this, could you/they confirm that they're not seeing the text twice, because I think they should.
Comment 16 cmeech 2012-03-08 00:19:16 UTC
We find having the item type descriptions along with the item type icon in the detail of the Bibl record provides useful information to our clients and staff using the OPAC. 

We believe that it would also be useful for staff in he staff client.

As we have numerous item types having unique icons for each item type is impractical, hence the value of the item type description.

Likewise having the item type descriptions along with the item type icon in the client search results would provide staff with useful information without much screen clutter.

Our motivation is not primarily based around alternate browsers or aiding the browsing of visually impaired users, but this is certainly a welcome addition.
Comment 17 Marcel de Rooy 2012-03-19 09:09:57 UTC
QA Comment:
Looks good to me. Marking as Passed QA.
Note that display depends on various settings like item-level_itypes, staff xslt options, noitemtypeimages.
If imageurl exists but switches to alternative text display, the description is duplicated (missing icon case): no problem.
Comment 18 Paul Poulain 2012-03-19 16:57:10 UTC
patch pushed.
Comment 19 Jared Camins-Esakov 2012-05-09 20:03:58 UTC
This bug will be included in the Koha 3.6.5 release.