Bug 7161 - Open Library - Larger image, Read, borrow and checked-out status
Summary: Open Library - Larger image, Read, borrow and checked-out status
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.10
Hardware: All All
: P3 enhancement (vote)
Assignee: Amit Gupta
QA Contact: Marcel de Rooy
URL:
Keywords:
: 6672 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-05 06:34 UTC by Savitra Sirohi
Modified: 2014-05-26 21:04 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Open Library - Larger image, Read, borrow and checked-out status (5.13 KB, patch)
2011-11-05 08:28 UTC, Amit Gupta
Details | Diff | Splinter Review
Bug-7161 Open Library - Larger image, Read, borrow and checked-out status (5.54 KB, patch)
2011-11-05 10:57 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Bug-7161 Open Library - Larger image, Read, borrow and checked-out status (4.10 KB, patch)
2012-05-31 16:27 UTC, Liz Rea
Details | Diff | Splinter Review
Bug-7161 Open Library - Larger image, Read, borrow and checked-out status (4.12 KB, patch)
2012-06-01 09:53 UTC, Jonathan Druart
Details | Diff | Splinter Review
Patch for 7161 (4.08 KB, patch)
2012-06-27 12:43 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Followup for 7161 (3.24 KB, patch)
2012-06-27 12:45 UTC, Marcel de Rooy
Details | Diff | Splinter Review
tini tiny cover on search results (65.25 KB, image/png)
2012-08-02 18:52 UTC, Nicole C. Engard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Savitra Sirohi 2011-11-05 06:34:17 UTC
Modified Open Library JS to:

1. Use jscmd=data instead of default, this provides ebooks availability information. This will allow us to display read/borrow/checkedout icons

2. Show larger image in opac-detail page

3. Show read/borrow/checked-out status in opac-detail page below the image
Comment 1 Savitra Sirohi 2011-11-05 06:35:25 UTC
*** Bug 6672 has been marked as a duplicate of this bug. ***
Comment 2 Amit Gupta 2011-11-05 08:28:07 UTC Comment hidden (obsolete)
Comment 3 Dobrica Pavlinusic 2011-11-05 10:57:54 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2011-12-12 10:59:59 UTC
QA Comments:

Thanks for your work. Could you clarify/modify please following points: 

I did not find an example on short notice for ebooks with availability information/icon.
There is a new function keys; but I couldn't see a call for it.
Same for get_cover; only call is in comments.

Some further questions on the code:
A console debug message is still present.
A regex call before creating Preview div has been eliminated; the reason for doing that is not made clear in this report. Can imagine that is was not really needed.
A variable a is filled with element a and modified href. But later on an element a is manually appended with yet another book.url. Not clear?
Comment 5 Nicole C. Engard 2012-02-10 12:13:19 UTC
I'd like to see the larger open library images in 3.8 - should this patch be broken in to parts so that such a simple fix can be pushed while the other parts are worked on?
Comment 6 Liz Rea 2012-05-31 16:27:36 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2012-06-01 09:53:43 UTC Comment hidden (obsolete)
Comment 8 Paul Poulain 2012-06-09 16:34:15 UTC
Marcel, you already made a 1st QA, so I let this one for you. Looking at the code I don't see anything wrong
Comment 9 Marcel de Rooy 2012-06-25 13:35:04 UTC
(In reply to comment #8)
> Marcel, you already made a 1st QA, so I let this one for you. Looking at the
> code I don't see anything wrong

Will be looking at this shortly..
Comment 10 Marcel de Rooy 2012-06-27 12:43:42 UTC
Created attachment 10539 [details] [review]
Patch for 7161

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
June 27, 2012: Removing unused function keys from openlibrary.js.
Comment 11 Marcel de Rooy 2012-06-27 12:45:54 UTC
Created attachment 10540 [details] [review]
Followup for 7161

Only whitespace changes to fix indentation after tab removal.
Comment 12 Marcel de Rooy 2012-06-27 12:48:33 UTC
Earlier comments have been implemented. Did some minor corrections myself on unused function and whitespace.
Marking as Passed QA now.
Comment 13 Nicole C. Engard 2012-08-02 18:52:47 UTC
Created attachment 11312 [details]
tini tiny cover on search results

My bug was marked a duplicate of this - but this didn't fix my my bug which was that the open library images are too small to see on the search results.
Comment 14 Nicole C. Engard 2012-11-17 01:04:02 UTC
The images on the search results for open library are still pretty tiny - can we update those to be somewhere between the size that's there now and the size that's on the detail page?
Comment 15 Nicole C. Engard 2013-02-19 12:05:25 UTC
Bug 9660 addresses the search results issue.

Nicole