Bug 7280 - Can't place hold without selecting on list
Summary: Can't place hold without selecting on list
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Ian Walls
URL: /cgi-bin/koha/opac-shelves.pl?viewshe...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-30 17:37 UTC by Nicole C. Engard
Modified: 2013-12-05 20:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (1.24 KB, patch)
2011-11-30 17:53 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 7280 - can't place hold without selecting on list (1.25 KB, patch)
2011-12-01 08:12 UTC, Chris Cormack
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7289: Adds editionstatement field in neworderempty (93.02 KB, patch)
2012-02-12 18:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 7289: Add biblioitems.editionstatement to missing sql files (40.86 KB, patch)
2012-02-12 18:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7289: Adds editionstatement field in neworderempty (93.02 KB, patch)
2012-02-12 18:30 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-11-30 17:37:32 UTC
When on a list if you click the place hold link below a title it says 'no item selected' but that error should only appear if you try to place a hold on multiple items using the place hold link at the top of the list.
Comment 1 Owen Leonard 2011-11-30 17:53:36 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2011-12-01 08:12:36 UTC
Created attachment 6484 [details] [review]
Bug 7280 - can't place hold without selecting on list

JavaScript was looking for clicks on links with class "hold,"
and incorrectly triggering the check for checked checkboxes.
Making the selection stricter lets the JS function as it should
while allowing people to place individual holds directly.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 3 Ian Walls 2011-12-01 12:49:07 UTC
Template only change, easy to read, marking as Passed QA
Comment 4 Paul Poulain 2011-12-06 17:57:19 UTC
patch pushed, please test

I had some trouble reproducing the error: it was because I tried to click on the "hold" button below the title when at least one checkbox was checked. In this case, the message was not appearing !

(severity lowered to "normal", it was easy to place a hold even with this bug)
Comment 5 Katrin Fischer 2012-02-12 18:29:31 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2012-02-12 18:29:47 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2012-02-12 18:30:22 UTC Comment hidden (obsolete)
Comment 8 Jared Camins-Esakov 2012-12-31 00:35:41 UTC
There have been no further reports of problems so I am marking this bug resolved.