Bug 7339 - Help System in IE8 Does Not Load With 500 Error
Summary: Help System in IE8 Does Not Load With 500 Error
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Browser compatibility (show other bugs)
Version: master
Hardware: PC Windows
: P5 - low critical (vote)
Target Milestone: Oldversions
Assignee: Owen Leonard
QA Contact:
URL:
Whiteboard:
Keywords:
: 8403 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-08 18:07 UTC by Larry Zuares
Modified: 2018-12-16 19:34 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Patch to fix problem in IE9, 7 and 8 still broken however. (1.14 KB, patch)
2011-12-20 00:45 UTC, Duncan
Details | Diff | Splinter Review
[SIGNED-OFF] Small fix to allow help popup in IE9, not 7 or 8 - bug 7339 (1.24 KB, patch)
2012-02-07 15:59 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Zuares 2011-12-08 18:07:52 UTC
When attempting to load the help system [?], I receive a 500 error from both IE8 and IE9 on two different library systems/servers.
Comment 1 Owen Leonard 2011-12-08 18:20:26 UTC
Confirmed in master.
Comment 2 Owen Leonard 2011-12-08 18:21:18 UTC
Template process failed: file error - /koha-tmpl/intranet-tmpl/prog/en/modules/help/.tt: not found at /C4/Templates.pm line 125.

For help, please send mail to the webmaster (webmaster@oleonard-desktop), giving this error message and the time and date of the error. 

Software error:
[Thu Dec  8 13:19:38 2011] help.pl: Template process failed: file error - e/koha-tmpl/intranet-tmpl/prog/en/modules/help/.tt: not found at /C4/Templates.pm line 125.
 at /usr/share/perl/5.12/CGI/Carp.pm line 354
	CGI::Carp::realdie('[Thu Dec  8 13:19:38 2011] help.pl: Template process failed: ...') called at /usr/share/perl/5.12/CGI/Carp.pm line 446
	CGI::Carp::die('Template process failed: ', 'Template::Exception=ARRAY(0x8bedbd0)') called at /C4/Templates.pm line 125
	C4::Templates::output('C4::Templates=HASH(0x8b40064)') called at /help.pl line 42

For
Comment 3 Larry Zuares 2011-12-08 18:23:21 UTC
Help system will open if right-clicked and opened in new tab or new window, but not directly.
Comment 4 Duncan 2011-12-20 00:45:15 UTC Comment hidden (obsolete)
Comment 5 Gaetan Boisson 2012-01-17 08:18:06 UTC
In firefox and chromium, a similar error is generated when clicking on the [?] link on the admin home page (but only on this page).
Comment 6 Owen Leonard 2012-01-24 15:13:00 UTC
(In reply to comment #5)
> In firefox and chromium, a similar error is generated when clicking on the [?]
> link on the admin home page (but only on this page).

This page? /cgi-bin/koha/admin/admin-home.pl

I don't get that error from Firefox 9.0.1 or Chrome 16.0.912.77 m on Windows 7, nor from Chrome 16.0.912.75 or Firefox 9.0.1 on Ubuntu 11.10.
Comment 7 Gaetan Boisson 2012-01-24 16:31:05 UTC
indeed, i had it on several instances but just saw it working properly on another one. forget comment #5!
Comment 8 Owen Leonard 2012-02-07 15:58:33 UTC
I tested this in IE9 using Biblibre's custom sandbox system (well done Biblibre!). I found that the patch fixes the problem in IE9.

However, I discovered another issue which seems to affect all browsers. If you click the help link on the home page when the URL looks like this:

http://my.koha.test.example.com

...it doesn't work. It does work if the URL looks like this:

http://my.koha.test.example.com/cgi-bin/koha/mainpage.pl

This patch seems to be an improvement, but even if it is pushed the bug should not be marked as resolved.
Comment 9 Owen Leonard 2012-02-07 15:59:42 UTC Comment hidden (obsolete)
Comment 10 Ian Walls 2012-02-07 16:26:54 UTC
One line template only change.  Marking as Passed QA.
Comment 11 Paul Poulain 2012-02-10 14:13:08 UTC
Duncan, when you endorse a bug, don't forget to assign it to yourself !

patch pushed
(tested everything is still OK under FF)
Comment 12 Jared Camins-Esakov 2012-05-23 12:59:53 UTC
This fix was included in the 3.6.x branch prior to 3.6.4.
Comment 13 Larry Zuares 2012-05-24 12:06:12 UTC
I also notice this behavior. Is there any way to generate the help file for /cgi-bin/koha/mainpage.pl while on the root URL?

(In reply to comment #8)
> I tested this in IE9 using Biblibre's custom sandbox system (well done
> Biblibre!). I found that the patch fixes the problem in IE9.
> 
> However, I discovered another issue which seems to affect all browsers. If
> you click the help link on the home page when the URL looks like this:
> 
> http://my.koha.test.example.com
> 
> ...it doesn't work. It does work if the URL looks like this:
> 
> http://my.koha.test.example.com/cgi-bin/koha/mainpage.pl
> 
> This patch seems to be an improvement, but even if it is pushed the bug
> should not be marked as resolved.
Comment 14 Owen Leonard 2012-07-10 13:44:31 UTC
*** Bug 8403 has been marked as a duplicate of this bug. ***
Comment 15 Owen Leonard 2012-11-29 10:40:48 UTC
I managed to finally test this in IE7, and it doesn't look like this bug affects it anymore. On the other hand, help in IE7 doesn't load the right help page either (always the "Okay I can log in") page. But it's probably time to give up on IE7 anyway.
Comment 16 Zeno Tajoli 2015-03-19 07:35:15 UTC
IE 7 is now not supported by Koha.
Bug closed
Comment 17 Zeno Tajoli 2015-03-19 07:35:59 UTC
The same for IE 8