Bug 7352 - moremember.pl generates error in Template.pm related to missing $key value
Summary: moremember.pl generates error in Template.pm related to missing $key value
Status: RESOLVED DUPLICATE of bug 7630
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Ian Walls
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-13 17:17 UTC by Fred P
Modified: 2012-06-29 15:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred P 2011-12-13 17:17:17 UTC
This is similar to bug 6840, but generating an error from the patron quick search (search field at the top of the patron screen). We received errors related to Template.pm missing a $key value. The patch for bug 6840 partially patches the error, but still generates tons of log messages when circ accesses the patron detail screen, so we altered the moremember.pl around line 474 to omit the "$error => 1," and editing the error parameter as follows:

---------------------------------------------------
    overdues_exist  => $overdues_exist,
    error           => 0,
    StaffMember     => ($category_type eq 'S'),
---------------------------------------------------


Then we added this status check for errors to the moremember.pl at new line 485, following the close of the original template value definition:
---------------------------------------------------

#addition to test error parameter status
if ( $error ) {
	$template -> param (
		$error => 1,
		error => 1,
	);
}

-----------------------------------------
Here is the original error message:

moremember.pl: Use of uninitialized value $key in hash element at /home/koha/kohaclone/C4/Templates.pm line 227., referer: http://koha.smfpl.org/cgi-bin/koha/members/member.pl

Here is the error message, after patching 6801:

moremember.pl: Problem = a value of 1 has been passed to param without key at /home/koha/kohaclone/C4/Templates.pm line 230., referer: http://koha.smfpl.org/cgi-bin/koha/circ/circulation.pl

After our patch, listed above, there are no further error messages being generated from the moremember.pl patron detail screen.
Comment 1 Mark Tompsett 2012-06-05 03:39:28 UTC
I believe that implementing my suggestion on bug 7630 would solve this problem too.
Comment 2 Mark Tompsett 2012-06-29 14:16:53 UTC
I believe the patch I just submitted to Bug 7630 will make this bug report obsolete.
Comment 3 Mark Tompsett 2012-06-29 15:04:19 UTC

*** This bug has been marked as a duplicate of bug 7630 ***