Bug 7380 - Can't filter patron search on detail page
Summary: Can't filter patron search on detail page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Katrin Fischer
URL:
Whiteboard:
Keywords:
: 10316 12982 (view as bug list)
Depends on: 11944 13596
Blocks: 14508
  Show dependency treegraph
 
Reported: 2011-12-27 14:52 UTC by Nicole C. Engard
Modified: 2016-12-05 21:23 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 7380: Refactor the patron search box header (12.74 KB, patch)
2014-07-15 10:50 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 7380: Refactor the patron search box header (12.72 KB, patch)
2014-11-03 14:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 7380: Refactor the patron search box header (12.73 KB, patch)
2015-01-14 15:38 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 7380: Refactor the patron search box header (12.91 KB, patch)
2015-01-14 17:57 UTC, Marc Véron
Details | Diff | Splinter Review
[Signed-off] Bug 10177 - whitespace is a valid password causing pernicious perturbations. (1.63 KB, patch)
2015-01-18 08:38 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 7380: Refactor the patron search box header (11.75 KB, patch)
2015-04-14 10:14 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 7380: Rename filter to avoid confusion (5.12 KB, patch)
2015-04-14 10:14 UTC, Jonathan Druart
Details | Diff | Splinter Review
Revert "Bug 13189: (QA Followup) Unit Tests" (1.88 KB, patch)
2015-04-17 13:14 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 7380: Refactor the patron search box header (11.81 KB, patch)
2015-04-17 13:16 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 7380: Rename filter to avoid confusion (5.19 KB, patch)
2015-04-17 13:16 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 7380: Refactor the patron search box header (11.88 KB, patch)
2015-04-17 13:37 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 7380: Rename filter to avoid confusion (5.26 KB, patch)
2015-04-17 13:38 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 7380: Add tests for TT plugins (3.26 KB, patch)
2015-04-17 15:40 UTC, Jonathan Druart
Details | Diff | Splinter Review
k (3.32 KB, patch)
2015-04-17 20:41 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 7380: Add tests for TT plugins (3.32 KB, patch)
2015-04-17 20:43 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-12-27 14:52:33 UTC
There is no [+] on patron search from patron detail page like there is on the main patron's page. It should be in all places.
Comment 1 Owen Leonard 2013-05-23 16:16:34 UTC
*** Bug 10316 has been marked as a duplicate of this bug. ***
Comment 2 Nicole C. Engard 2013-08-02 14:14:07 UTC
upping severity on this because it causes a lot of confusion in the trainings i'm doing lately
Comment 3 Katrin Fischer 2014-07-12 11:33:06 UTC
Tested on current master:

- Patron module main page
- [+] is there and working

- Patron detail page
- [+] is there, but not working correctly. The additional fields don't show up.
Comment 4 Jonathan Druart 2014-07-15 10:50:05 UTC Comment hidden (obsolete)
Comment 5 HB-NEKLS 2014-08-09 15:16:37 UTC
Jonathan, I tried applying this patch to master to test it, and received this message:

fatal: sha1 information is lacking or useless (Koha/Template/Plugin/Branches.pm).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 7380: Refactor the patron search box header

I'm brand new to testing patches with git bz, so it may be my setup, but other patches have applied successfully.
Comment 6 Jonathan Druart 2014-08-18 10:16:46 UTC
This patch depends on bug 11944.
Comment 7 Owen Leonard 2014-10-23 16:38:05 UTC
I tried to apply this on top of biblibre/ft/bug_11944 and still got the same error Heather did. Am I testing this incorrectly?
Comment 8 Jonathan Druart 2014-11-03 14:15:38 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2014-11-03 14:17:24 UTC
It applied correctly here but with some "Auto-merging".
Could you retry with this new patch please?
Comment 10 Katrin Fischer 2014-11-03 21:49:19 UTC
Hm not sure what's wrong - I tried applying 11944 first, but got a couple of conficts. 7380 won't apply alone either.
Comment 11 Jonathan Druart 2014-11-04 08:09:20 UTC
You should use the branch ft/bug_11944, not the patches on the bug report.
Comment 12 Jonathan Druart 2015-01-14 15:38:40 UTC Comment hidden (obsolete)
Comment 13 Jonathan Druart 2015-01-14 15:39:05 UTC
Rebase against master (with 11944), small conflict fixed.
Comment 14 Marc Véron 2015-01-14 17:57:47 UTC Comment hidden (obsolete)
Comment 15 Kyle M Hall 2015-01-16 16:34:25 UTC
The library and category filters on moremember.pl appear to be preset to the library and category of the patron you are viewing. This seems improper.
Comment 16 Marc Véron 2015-01-18 08:38:51 UTC Comment hidden (obsolete)
Comment 17 Marc Véron 2015-01-18 08:47:51 UTC
Comment on attachment 35342 [details] [review]
[Signed-off] Bug 10177 - whitespace is a valid password causing pernicious perturbations.

Sorry for the noise, mistaked wit bug number.
Comment 18 Jonathan Druart 2015-04-14 10:14:08 UTC Comment hidden (obsolete)
Comment 19 Jonathan Druart 2015-04-14 10:14:13 UTC Comment hidden (obsolete)
Comment 20 Jonathan Druart 2015-04-14 10:14:48 UTC
(In reply to Kyle M Hall from comment #15)
> The library and category filters on moremember.pl appear to be preset to the
> library and category of the patron you are viewing. This seems improper.

Thanks for the catch!
Should be fixed with the last patch.
Comment 21 Nicole C. Engard 2015-04-17 13:14:53 UTC Comment hidden (obsolete)
Comment 22 Nicole C. Engard 2015-04-17 13:15:40 UTC
Comment on attachment 38053 [details] [review]
Revert "Bug 13189: (QA Followup) Unit Tests"

Something strange is going on on my system - ignore me
Comment 23 Nicole C. Engard 2015-04-17 13:16:00 UTC Comment hidden (obsolete)
Comment 24 Nicole C. Engard 2015-04-17 13:16:20 UTC Comment hidden (obsolete)
Comment 25 Katrin Fischer 2015-04-17 13:37:54 UTC
Created attachment 38067 [details] [review]
[PASSED QA] Bug 7380: Refactor the patron search box header

A lot of page uses the patron search box header include (git grep
patron-search.inc for the list) and the branch and category lists are
not generated for all of them.

For instance, on a patron detail page, there is a [+] link, but nothing
append on clicking on it.

This patch add a new template plugin "Categories" to get all patron
categories from the templates.

Test plan:
1/ Verify the [+] is working on all patron page (if that works for 2,
that should work for all).
2/ Launch a search from the header box and verify the library and
category dropdown lists select the correct value.
3/ Launch a search on the patron search page (patron home) and verify
the search is working correctly on selecting a category and/or a library

Followed test plan. Works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Nicole Engard <nengard@bywatersolutions.com>
Signed-off-by: Katrin Fischer <katrin.fischer@bsz-bw.de>
Comment 26 Katrin Fischer 2015-04-17 13:38:00 UTC
Created attachment 38068 [details] [review]
[PASSED QA] Bug 7380: Rename filter to avoid confusion

The branchcode and categorycode parameter names are too common and are
confusing.
To remove the ambiguity, this patch renames them with branchcode_filter
and categorycode_filter.

Test plan:
1/ Go on the patron home page (members-home.pl)
2/ Fill the library and category dropdown list in the header search
3/ The patron result list appears and the filters (on the right) are
correctly set with what you have selected.
Make sure the ones in the header are also correctly selected.
4/ Click on a patron
5/ On the patron detail page (moremember.pl), the dropdown lists in the
header are not preselected.

Signed-off-by: Nicole Engard <nengard@bywatersolutions.com>
Signed-off-by: Katrin Fischer <katrin.fischer@bsz-bw.de>
Comment 27 Katrin Fischer 2015-04-17 13:46:11 UTC
Functionally I am fie with this, pushing it back to Jonathan asking nicely for some tests!
Comment 28 Jonathan Druart 2015-04-17 15:40:42 UTC Comment hidden (obsolete)
Comment 29 Katrin Fischer 2015-04-17 20:41:50 UTC Comment hidden (obsolete)
Comment 30 Katrin Fischer 2015-04-17 20:43:19 UTC
Created attachment 38108 [details] [review]
[PASSED QA] Bug 7380: Add tests for TT plugins

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 31 Katrin Fischer 2015-04-17 20:44:35 UTC
The new tests pass for me without any problem. They are differently named ot the existing plugin pathces where the directory structure is only reflected in the file name.
Comment 32 Tomás Cohen Arazi 2015-05-19 13:13:30 UTC
Patches pushed to master.

Good one Jonathan!
Comment 33 Tomás Cohen Arazi 2015-07-08 21:46:09 UTC
*** Bug 12982 has been marked as a duplicate of this bug. ***