Bug 7382 - normalization on isbn matching rule
Summary: normalization on isbn matching rule
Status: RESOLVED DUPLICATE of bug 10500
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-27 20:32 UTC by Nicole C. Engard
Modified: 2013-08-30 14:36 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
screenshot of matching rule interface (19.67 KB, image/png)
2011-12-27 20:42 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-12-27 20:32:33 UTC
It would be nice if when using isbn as a match point it normalized the ISBN first.  Now if one isbn ends in (pbk) and the other doesn't - but they're both the same number it doesn't match them and imports duplicates.
Comment 1 Katrin Fischer 2011-12-27 20:42:20 UTC
Created attachment 6935 [details]
screenshot of matching rule interface

I am not sure how it works - but there is a field for a normalization rule in the staff interface. So perhaps there is some 'hidden' feature that would allow doing this?
Comment 2 Magnus Enger 2011-12-28 10:35:27 UTC
Business::ISBN has functions to do stuff like that.
Comment 3 Albert Oller 2012-06-14 15:10:16 UTC
Hi,

according to the manual: Koha only has one 'Normalization rule' that removes extra characters such as commas and semicolons. The value you enter in this field is irrelevant to the normalization process.
Comment 4 JaTara Barnes 2013-06-05 01:43:20 UTC
What's a good starting point for getting this fixed? I'd love to help with this project.
Comment 5 Kyle M Hall 2013-08-30 14:36:51 UTC

*** This bug has been marked as a duplicate of bug 10500 ***