Bug 7690 - hidelostitems not working in Normal Display
Summary: hidelostitems not working in Normal Display
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low minor (vote)
Assignee: Fridolin SOMERS
QA Contact: Ian Walls
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-09 15:35 UTC by Nicole C. Engard
Modified: 2013-12-05 19:59 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
lost items showing in results (24.84 KB, image/png)
2012-03-09 15:35 UTC, Nicole C. Engard
Details
Proposed patch (6.00 KB, patch)
2012-08-09 14:03 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7690: hidelostitems not working in Normal Display (6.23 KB, patch)
2012-08-29 13:28 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-03-09 15:35:54 UTC
Created attachment 8122 [details]
lost items showing in results

In the OPAC if you are not using XSLT lost items show in the results even if you have hidelostitems set to not show them.
Comment 1 Fridolin SOMERS 2012-08-09 14:03:11 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2012-08-16 23:52:37 UTC
Is this still a problem?I can't reproduce it and also if we're going to remove hidelostitems (http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8619) do we need this patch?
Comment 3 Fridolin SOMERS 2012-08-17 08:06:10 UTC
(In reply to comment #2)
> Is this still a problem?I can't reproduce it and also if we're going to
> remove hidelostitems
> (http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8619) do we need
> this patch?

Yes it is still a problem, this bug concerns hidelostitems but also OpacHiddenItems behavior.

I forgot : to reproduce the but, hidden items must be unavailable (on loan, damaged, not for loan ...).

Tell me if you need a better test plan.
Comment 4 Nicole C. Engard 2012-08-17 13:18:25 UTC
I had lost items hidden in the opac and then did a search with XSLT turned off and lost items were hidden without this patch. A lost item won't be checked out in most cases, so the item was not checked out.
Comment 5 Fridolin SOMERS 2012-08-17 13:42:06 UTC
On my test environment (master revision and sandbox 2 database), I reproduce the bug.
hilelostitems is active. With 1 item available and 1 lost (itemlost=1), I get :
Availability: Copies available: Le Cannet (1), Lost (1).

Result page gets items from Zebra so after editing an item, don't forget to rebuild.
Comment 6 Owen Leonard 2012-08-29 13:28:41 UTC
Created attachment 11878 [details] [review]
[SIGNED-OFF] Bug 7690: hidelostitems not working in Normal Display

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Tested by toggling both the hidelostitems preference and the
OpacHiddenItems preference. Both work as expected in the normal
search results display.
Comment 7 Mason James 2012-09-14 15:11:43 UTC
(In reply to comment #6)
> Created attachment 11878 [details] [review]
> [SIGNED-OFF] Bug 7690: hidelostitems not working in Normal Display
> Signed-off-by: Owen Leonard <oleonard@myacpl.org>

patch looks good, passing QA…

$ koha-qa.pl 

testing 1 commit(s) (applied to commit 0acebb8)
 * f14ca82 Bug 7690: hidelostitems not working in Normal Display
      C4/Search.pm
      koha-tmpl/opac-tmpl/prog/en/modules/opac-results.tt

* C4/Search.pm                                                             OK
* koha-tmpl/opac-tmpl/prog/en/modules/opac-results.tt                      OK
Comment 8 Paul Poulain 2012-09-17 16:47:15 UTC
Patch pushed to master
Comment 9 Chris Cormack 2012-09-19 02:43:49 UTC
Template change, but no string changes, pushing to 3.8.x will be in 3.8.5