Bug 7701 - Error when sending serial alerts
Summary: Error when sending serial alerts
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low critical (vote)
Assignee: Jared Camins-Esakov
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on:
Blocks: 7658
  Show dependency treegraph
 
Reported: 2012-03-11 16:07 UTC by Jared Camins-Esakov
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 7701: Error when sending serial alerts (1.14 KB, patch)
2012-03-11 16:10 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7701: Error when sending serial alerts (1.76 KB, patch)
2012-03-28 06:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 7701: Error when sending serial alerts (1.87 KB, patch)
2012-03-29 06:44 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2012-03-11 16:07:59 UTC
Probably due to bug 6875, C4::Letters is no longer used by C4::Serials, so that when SendAlerts is called (exactly when this happens is a mystery to me), you will get an error. Adding a "require C4::Letters;" and prefixing SendAlerts to C4::Letters:: should fix it.
Comment 1 Jared Camins-Esakov 2012-03-11 16:10:33 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2012-03-28 06:29:46 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2012-03-28 06:30:44 UTC
I am changing the severity because without the patch serial receive does not work when you have a patron subscribed to alerts for new serial issues.
Comment 4 Marcel de Rooy 2012-03-28 12:09:19 UTC
Are you both sure that this is the fix:
C4::Leters::SendAlerts
??
Changing to Failed QA. Please correct.
Comment 5 Katrin Fischer 2012-03-28 12:18:06 UTC
Good catch Marcel - perhaps would not send a mail in that case but stop the Perl error? I could only check the receive part.
Comment 6 Katrin Fischer 2012-03-29 06:44:34 UTC
Created attachment 8679 [details] [review]
[SIGNED-OFF] Bug 7701: Error when sending serial alerts

Probably due to bug 6875, C4::Letters is no longer used by C4::Serials, so that
when SendAlerts is called (exactly when this happens is a mystery to me), you
will get an error. Adding a "require C4::Letters;" and prefixing SendAlerts to
C4::Letters:: should fix it.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Patch fixes the perl error. Steps to reproduce:

1) Create a subscription and set patron notification to "Routling list" -
this is necessary, so that a link to email notifications shows up in the OPAC.
2) Search for the serial record in the OPAC and click on the more details
view from the subscriptions tab. Subscribe to email notifications.
3) Go back into the serials module and receive and issue for the serial.
Before the patch a nasty perl error will be shown, after the patch
receiving works.

I couldn't confirm that the email was sent out with my setup, but this patch
certainly fixes serial receive.

[Update 2011-02-29] Fixed the typo and retested. Looks good, but couldn't check
if the mail was actually sent.
Comment 7 Marcel de Rooy 2012-03-29 06:51:59 UTC
Looks even better ;)
Comment 8 Paul Poulain 2012-03-29 09:16:50 UTC
I pushed the patch because it fixes an obvious problem, but please test !
Katrin, you should have had a Perl error when trying to run C4::Leters::SendAlerts. If you hadn't then it's probably that those lines have not been executed
Comment 9 Katrin Fischer 2012-03-29 13:27:27 UTC
:(

I am not sorry what went wrong in my tests, but I am worried about getting no email. I know this used to work on our 3.2.2 installations and want to do more tests, but not sure when I will have the time. Could someone with working email setup test on master and report of a mail is sent or not? The template used normally is RLIST. I noted the test plan in my sign off comment.
Comment 10 Katrin Fischer 2012-03-31 23:19:33 UTC
Retested this and sending out serial alerts works perfectly fine (see bug 7658)