Bug 7715 - Add biblio.subtitle and appropriate mappings to MARC frameworks
Summary: Add biblio.subtitle and appropriate mappings to MARC frameworks
Status: RESOLVED DUPLICATE of bug 11529
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Ian Walls
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 15:05 UTC by Ian Walls
Modified: 2017-09-11 17:12 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 7715: Add biblio.subtitle and appropriate MARC21 framework mappings (115.65 KB, patch)
2012-03-19 22:46 UTC, Ian Walls
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2012-03-14 15:05:43 UTC
There is more and more demand for the subtitle of a material to be shown along the main portion of the title.  Right now, the only way to extra this information is to process the MARC record, which involves costly XML processing.  It would be better to stash the subtitle in the biblio table, so it can be accessed just with SQL.

Necessary changes:

Installation:

add subtitle to biblio table, after title and before uniform title

add the appropriate mappings to MARC21, UNIMARC and NORMARC frameworks.  Respect any pre-existing mapping on the 245$b field or 200$e fields

Usage:

Add subtitle to SQL queries for title

Export subtitle to templates along with title

Display subtitle token (if it exists) after title


Previous RFC:  http://wiki.koha-community.org/wiki/Add_column_to_biblio_table_for_subtitle_/_remainder_of_title_RFC
Comment 1 Ian Walls 2012-03-19 22:15:38 UTC
Hmmm, looks like for several of the French UNIMARC frameworks, 200$e is mapped to biblioitems.volume.  I assume this was done as a workaround?  Or am I missing something?

At any rate, my initial patch will not include UNIMARC until I can be sure I'm not going to break things.
Comment 2 Ian Walls 2012-03-19 22:46:14 UTC
Created attachment 8316 [details] [review]
Bug 7715:  Add biblio.subtitle and appropriate MARC21 framework mappings

This patch adds biblio.subtitle and deletedbiblio.subtitle to the Koha DB
structure, and maps the MARC21 (and NORMARC) frameworks 245$b field to this
database column if it's not already mapped (or is mapped to the non-existent
bibliosubtitle.subtitle field).

To Test:

Upgrade (on MARC21 installation)
1.  In one framework, map 245$b to an existent database field
2.  Run updatedatabase.pl.  You should now have the biblio.subtitle field
3.  Check the framework to confirm your manual mapping still holds
4.  Check another framework, one where 245$b was not mapped, to see that is now is
5.  Add a biblio with a subtitle; the value of the 245$b should wind up in the database

New installation
1.  Install a new MARC21 database
2.  Add a biblio with a subtitle; the value of the 245$b should wind up in the database,
in the biblio.subtitle field
Comment 3 Ian Walls 2012-03-19 22:47:20 UTC
This patch adds the database field and frameworks only, and only for MARC21
Comment 4 Owen Leonard 2012-03-23 15:50:27 UTC
This solves the problem we faced previously where subtitle was in biblioitems and complicated joins were required to display it. However, the advantage of the "Keywords to MARC mapping" method is that you can add information besides 245$b: 245$h, 245$n or 245$p for instance. We stretch the definition of "subtitle" so that we can get more information into the display of title into more places in the intranet.
Comment 5 Marijana Glavica 2012-06-10 15:15:33 UTC
The problem with having "subtitle" field in a database is that there is no such field in MARC21 nor in UNIMARC. 
MARC21 has 245$b - remainder of title (subtitle, paralel title, etc.)
UNIMARC has 200$e - other title information (subtitle and other information subordinate to title proper)

On the other hand, from the practical point of view, it is very tempting to have separate database filed for this, because in SQL reports title is often  not enough. But than, for some cases, title + subtitle is also not enough because we also have multipart items so we need title and subtitle together with number of part and title of part.

Keywords to MARC mapping is much nicer solution, but it is not usable in SQL reports. But than, for SQL reports we now can use MySQL XML handling function, so this is not so big problem as before MySQL 5.1.5

So in conclusion, I vote against having subtitle field in database. If we go (back) in that direction, the name of this field should not be subtitle.
Comment 6 Owen Leonard 2012-07-20 13:44:29 UTC
What about using the "Keywords to MARC mapping" setting to determine what information is pulled into the new quasi-subtitle field? I guess that would present problems if you wanted to modify the mapping. You'd have to run some kind of rebuild script.
Comment 7 Liz Rea 2016-07-27 01:03:12 UTC

*** This bug has been marked as a duplicate of bug 11529 ***