Bug 7770 - usage of OPACBaseURL
Summary: usage of OPACBaseURL
Status: RESOLVED DUPLICATE of bug 5010
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Paul Poulain
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-21 10:08 UTC by Laurence Rault
Modified: 2015-03-31 09:01 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurence Rault 2012-03-21 10:08:02 UTC
System preferences OPACBaseURL is used at different places in koha, for instance : 
- CAS authentication (7745)
- OAI
- file upload (6874)

Description of the syspref indicates that http:// will automatically be added.

We tested that for oai biblio url and for CAS, it is not the case, and we have to fill http:// in the syspref.

The usage of this syspref in Koha and how it should be really filled should be precised so that it is consistent everywhere
Comment 1 Matthias Meusburger 2012-03-21 10:14:38 UTC
To my opinion, http:// should not be added automatically, for one simple reason: it just might not be http:// !

OPAC might be using https, and in that case, automatic prefill would be wrong.
Comment 2 Fridolin SOMERS 2014-02-06 14:09:20 UTC
(In reply to Matthias Meusburger from comment #1)
> To my opinion, http:// should not be added automatically, for one simple
> reason: it just might not be http:// !
> OPAC might be using https, and in that case, automatic prefill would be
> wrong.
+1
Comment 3 Nicole C. Engard 2014-06-06 17:32:02 UTC
This also effects RSS feeds I believe.
Comment 4 Jonathan Druart 2015-03-31 09:01:02 UTC

*** This bug has been marked as a duplicate of bug 5010 ***