Bug 7789 - Add translations of item type and authorized value descriptions
Summary: Add translations of item type and authorized value descriptions
Status: RESOLVED DUPLICATE of bug 14100
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Frédéric Demians
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 09:29 UTC by Owen Leonard
Modified: 2015-10-24 20:26 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Mockup of a possible implementation for Item Types (31.02 KB, image/png)
2012-03-22 09:29 UTC, Owen Leonard
Details
Mockup which shows handling of a default set (no language code) (31.68 KB, image/png)
2012-03-22 09:32 UTC, Owen Leonard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2012-03-22 09:29:04 UTC
Created attachment 8471 [details]
Mockup of a possible implementation for Item Types

Since descriptions of item types and authorized values are stored in the database, there is no way to translate them. This creates a problem if the descriptions in the database are in one language but your user has switched to another.

I propose that we add a language column to the itemtypes and authorised_values tables. For existing installations the existing data would remain with an empty "language" value, and this option would be displayed by default. If a library adds a set of language-specific translations that set will be displayed when that language is chosen.

I think the entry form would not require extensive updating, but the display of existing values in Administration might. I'm thinking that each language's values might be displayed in a separate tab. See the attached mockup. The tabs could be displayed based on enabled languages.
Comment 1 Owen Leonard 2012-03-22 09:32:37 UTC
Created attachment 8473 [details]
Mockup which shows handling of a default set (no language code)

This mockup shows I imagine it would look if you had a default set (an existing set of values which didn't include a language code) plus other languages.
Comment 2 Owen Leonard 2012-03-22 16:27:18 UTC
As Katrin points out, we can't simply add more lines to itemtypes, duplicating the existing ones with translated versions since itemtypes are used for things like circulation rules. For this we might have to create a new authorized value for configuring item type description? This would certainly create a lot more complexity.
Comment 3 Frédéric Demians 2012-03-22 16:48:27 UTC
(In reply to comment #2)
> As Katrin points out, we can't simply add more lines to itemtypes,
> duplicating the existing ones with translated versions since itemtypes are
> used for things like circulation rules. For this we might have to create a
> new authorized value for configuring item type description? This would
> certainly create a lot more complexity.

How will it works? How to fine the appropriate description depending on language?
Comment 4 Katrin Fischer 2012-03-22 16:54:43 UTC
I think we are still in the early planning stage here... I think we can agree that it would be nice to have multilanguage support for itemtype and authorized value descriptions.

Now... how to get there?

I think talking about it we are thinking more and more of a table holding the language codes and translated descriptions.
Perhaps use the existing description in the table as a fallback, use the authorised value id + a code telling that it's being referenced from authorized values in a separate table to refer to translated descriptions? (hope that does make sense)
Comment 5 Julian Maurice 2015-10-23 12:13:04 UTC
Duplicate of bug 14100 ?
Comment 6 Katrin Fischer 2015-10-24 20:26:49 UTC
It is! Discussion from 2012... time flies!

*** This bug has been marked as a duplicate of bug 14100 ***