Bug 7851 - circ/circulation.pl plack scoping
Summary: circ/circulation.pl plack scoping
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Dobrica Pavlinusic
QA Contact: Ian Walls
URL:
Keywords:
Depends on:
Blocks: 7172
  Show dependency treegraph
 
Reported: 2012-03-29 22:19 UTC by Marijana Glavica
Modified: 2013-12-05 20:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 7851 - circ/circulation.pl plack scoping (2.14 KB, patch)
2012-03-30 17:06 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
[Signed-off] Bug 7851 - circ/circulation.pl plack scoping (2.21 KB, patch)
2012-04-02 12:23 UTC, Alex Arnaud
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marijana Glavica 2012-03-29 22:19:12 UTC

    
Comment 1 Dobrica Pavlinusic 2012-03-30 16:56:07 UTC
Variable "$totalprice" is not available at /srv/koha/circ/circulation.pl line 448.
Variable "%renew_failed" is not available at /srv/koha/circ/circulation.pl line 456.
Variable "$todaysdate" is not available at /srv/koha/circ/circulation.pl line 458.
Variable "@todaysissues" is not available at /srv/koha/circ/circulation.pl line 459.
Variable "@relissues" is not available at /srv/koha/circ/circulation.pl line 459.
Variable "@previousissues" is not available at /srv/koha/circ/circulation.pl line 461.
Variable "@relprevissues" is not available at /srv/koha/circ/circulation.pl line 461.
Subroutine build_issue_data redefined at /srv/koha/circ/circulation.pl line 422.
Comment 2 Dobrica Pavlinusic 2012-03-30 17:06:51 UTC Comment hidden (obsolete)
Comment 3 Alex Arnaud 2012-04-02 12:22:40 UTC
1. go to circulation page
2. verify errors in console output of plack
    => yes many errors as described in comment 2
3. apply patch
4. reload and verify that errors are gone

Errors are gone.

Also tested if it still works without plack: ok !

Signing off
Comment 4 Alex Arnaud 2012-04-02 12:23:45 UTC
Created attachment 8766 [details] [review]
[Signed-off] Bug 7851 - circ/circulation.pl plack scoping

Errors:

Variable "$totalprice" is not available at /srv/koha/circ/circulation.pl line 448.
Variable "%renew_failed" is not available at /srv/koha/circ/circulation.pl line 456.
Variable "$todaysdate" is not available at /srv/koha/circ/circulation.pl line 458.
Variable "@todaysissues" is not available at /srv/koha/circ/circulation.pl line 459.
Variable "@relissues" is not available at /srv/koha/circ/circulation.pl line 459.
Variable "@previousissues" is not available at /srv/koha/circ/circulation.pl line 461.
Variable "@relprevissues" is not available at /srv/koha/circ/circulation.pl line 461.

Test scenario:
1. go to circulation page
2. verify errors in console output of plack
3. apply patch
4. reload and verify that errors are gone

Signed-off-by: Alex Arnaud <alex.arnaud@biblibre.com>
Comment 5 Ian Walls 2012-04-03 15:42:40 UTC
more rescoping 'my' to 'our'.  Fixes issues caused by the nested build_issues_data subroutine... ideally this subroutine should be removed from circ/circulation.pl (and it's hideous twin brother from members/moremember.pl), but that's a larger project than just adjusting scopes.

Passed QA.
Comment 6 Jared Camins-Esakov 2012-12-31 00:51:14 UTC
There have been no further reports of problems so I am marking this bug resolved.