Bug 8012 - defaultSortOrder and OPACdefaultSortOrder are set to "ascending" on install
Summary: defaultSortOrder and OPACdefaultSortOrder are set to "ascending" on install
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low trivial (vote)
Assignee: D Ruth Bavousett
QA Contact: Jonathan Druart
URL:
Keywords:
: 4221 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-27 02:03 UTC by D Ruth Bavousett
Modified: 2013-12-05 19:59 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (3.50 KB, patch)
2012-08-17 12:45 UTC, D Ruth Bavousett
Details | Diff | Splinter Review
Bug 8012: default values for defaultSortField/defaultSortOrder NULL on install (3.55 KB, patch)
2012-08-18 02:34 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description D Ruth Bavousett 2012-04-27 02:03:05 UTC
...which, given that defaultSortField and OPACdefaultSortField are both set to "relevance" out of the box, is just plain silly--the results are sorted with *lowest* relevance first!

Trivial to fix, but can save new installs mucho frustration...
Comment 1 D Ruth Bavousett 2012-04-27 02:10:23 UTC
A little investigation showed that this value is actually initialized NULL--which you can't set in the interface--which shows "ascending."  But the actual behavior of the sort is kinda screwy by that.  To me, it makes sense to initialize the value to SOMETHING...
Comment 2 D Ruth Bavousett 2012-08-17 12:45:31 UTC Comment hidden (obsolete)
Comment 3 Chris Cormack 2012-08-18 02:34:34 UTC
Created attachment 11675 [details] [review]
Bug 8012: default values for defaultSortField/defaultSortOrder NULL on install

...which *looks* like "relevance/ascending" in the staff client, which doesn't make sense.
This patch initializes the values at "relevance/descending", which is a functional
combination.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 4 Jonathan Druart 2012-08-20 11:49:15 UTC
QA Comment:

Set the default sort order to relevance desc. Seems logical.

Marked as Passed QA
Comment 5 Fridolin SOMERS 2012-08-20 15:08:27 UTC
*** Bug 4221 has been marked as a duplicate of this bug. ***
Comment 6 Paul Poulain 2012-09-03 13:20:06 UTC
Patch pushed to master
Comment 7 Chris Cormack 2012-09-03 20:46:58 UTC
Pushed to 3.8.x, will be in 3.8.5