Bug 8135 - Services Directory and itemrecorddisplay.pl File Missing After Install
Summary: Services Directory and itemrecorddisplay.pl File Missing After Install
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 3.8
Hardware: All All
: P1 - high critical (vote)
Assignee: Chris Cormack
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 7178
  Show dependency treegraph
 
Reported: 2012-05-22 07:14 UTC by David Cook
Modified: 2019-06-27 09:24 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8135 : Fix installer to copy services/ dir (848 bytes, patch)
2012-05-22 07:36 UTC, Chris Cormack
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8135 : Fix installer to copy services/ dir (911 bytes, patch)
2012-05-22 08:32 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description David Cook 2012-05-22 07:14:58 UTC
We cloned the Koha git on 5 May 2012, and noticed today (22 May 2012) that while the cloned repository contains the Services directory and itemrecorddisplay.pl file, the installed folders are missing the above-mentioned directory and file. 

We just copied the files across directly, but it looks like there might be an issue with the installer. Has anyone else had this issue?

The absence of this script means that you can't place orders in the Acquisitions module when you have AcqCreateItem set to "placing an order", since you can't add any items and item quantity defaults to '0', which doesn't pass validation tests on submit.
Comment 1 Chris Cormack 2012-05-22 07:22:48 UTC
You mean after you ran perl Makefile.PL
make 
make install 

The files weren't copied over?

I can confirm they are in the tarball too

19:18 ~/src$ wget http://download.koha-community.org/koha-3.8.1.tar.gz
19:20 ~/src$ tar xzf koha-3.8.1.tar.gz 
19:20 ~/src$ ls koha-3.8.1/services/
itemrecorddisplay.pl

Will test the installer now
Comment 2 Chris Cormack 2012-05-22 07:24:53 UTC
Yep you are right

 './reviews'                   => 'INTRANET_CGI_DIR',
  './serials'                   => 'INTRANET_CGI_DIR',
  './skel'                      => 'NONE',

The Makefile.PL is not set up to copy that dir over.
Comment 3 Chris Cormack 2012-05-22 07:30:22 UTC
Bug 7178 commit eefc774e274ce8167f1063be5f9204a0d5cf5650 introduced this file, but the Makefile.PL was never updated to copy this file.

It was released in 3.8.0 and the fixed has missed 3.8.1

Ill attach a patch if you could sign off David we can hopefully get it into 3.8.2
Comment 4 Chris Cormack 2012-05-22 07:36:29 UTC Comment hidden (obsolete)
Comment 5 Julian Maurice 2012-05-22 08:32:00 UTC
Created attachment 9689 [details] [review]
[SIGNED-OFF] Bug 8135 : Fix installer to copy services/ dir

Tried to `perl Makefile.PL; make; make install` using "single" install mode.
On master, services/itemrecorddisplay.pl is not copied.
With the patch it is copied.
Signed off.
Comment 6 Ian Walls 2012-05-23 14:15:23 UTC
Consequence of bug 7178, adds new directory to Makefile.PL.  Marking Passed QA
Comment 7 Chris Cormack 2012-05-24 21:29:08 UTC
Will be in 3.8.2