Bug 8172 - Missing dereference marker for buildQuery parameter in addbooks.pl
Summary: Missing dereference marker for buildQuery parameter in addbooks.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-31 18:36 UTC by M. Tompsett
Modified: 2013-12-05 19:57 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Added a missing dereference marker for an array parameter. (1.28 KB, patch)
2012-06-29 14:30 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 8172 - Missing dereference marker for buildQuery parameter in addbooks.pl Added a dereference to an array parameter of buildQuery. (1.29 KB, patch)
2012-07-01 00:26 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 8172: Followup: Removes useless empty params (1.77 KB, patch)
2012-07-02 14:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 8172: Followup: Removes useless empty params (1.82 KB, patch)
2012-08-06 08:08 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description M. Tompsett 2012-05-31 18:36:40 UTC
my ( $builterror,$builtquery,$simple_query,$query_cgi,$query_desc,$limit,$limit_cgi,$limit_desc,$stopwords_removed,$query_type) = buildQuery(\@operators,\@operands,\@indexes,@limits,\@sort_by,undef,undef);

Which is roughly line 75 of addbooks.pl likely should have a \ on the @limits.
Because C4::Search.pm around line 1044 shows the parameters being treated the same.

I was hoping this would solve my Lingua::Stem::Snowball error, but I will have to continue to hunt deeper.
Comment 1 M. Tompsett 2012-06-12 09:58:49 UTC
I was looking originally at 3.6.3. I downloaded 3.8.1 and confirmed this bug exists in it as well.
Comment 2 M. Tompsett 2012-06-29 14:30:53 UTC Comment hidden (obsolete)
Comment 3 Chris Cormack 2012-07-01 00:26:10 UTC
Created attachment 10576 [details] [review]
Bug 8172 - Missing dereference marker for buildQuery parameter in addbooks.pl Added a dereference to an array parameter of buildQuery.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 4 Jonathan Druart 2012-07-02 14:19:03 UTC Comment hidden (obsolete)
Comment 5 Chris Cormack 2012-08-06 08:08:33 UTC
Created attachment 11372 [details] [review]
Bug 8172: Followup: Removes useless empty params

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 6 Jonathan Druart 2012-08-09 10:09:00 UTC
Simple patch, Marked as Passed QA
Comment 7 Chris Cormack 2012-08-10 07:24:17 UTC
Pushed to 3.8.x will be in 3.8.4
Comment 8 Paul Poulain 2012-08-29 13:38:43 UTC
Pushed to master today. Already in stable, so status set accordingly