Bug 8277 - item form not always showing when ordering
Summary: item form not always showing when ordering
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-20 15:10 UTC by Nicole C. Engard
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-06-20 15:10:45 UTC
When ordering in acquisitions the item form isn't always showing (see: http://screencast.com/t/USJxXyTO9). I have tested on 3 3.8.1 systems and see this on two of them .. I can't figure out what's going on, or why it works on one and not the others, but wanted to get the report out here.

Nicole
Comment 1 Nicole C. Engard 2012-06-20 15:11:54 UTC
I should note that AcqCreateItem  is set to 'placing an order' on all installs I tested.

Nicole
Comment 2 Albert Oller 2012-06-20 16:00:30 UTC
I've tested this on 3 systems, and found the problem with one of the systems.
Comment 3 Paul Poulain 2012-11-21 16:23:46 UTC
do you have ACQ framework on the broken setups ?
Comment 4 Nicole C. Engard 2012-11-21 16:33:22 UTC
Yes.
Comment 5 Paul Poulain 2012-11-21 16:43:29 UTC
(In reply to comment #4)
> Yes.

I've no idea then. sorry
Comment 6 shalomchong 2013-04-10 02:25:44 UTC
my item form was blank all the time when i use ie as my web browser. but the problem solved when i use google chrome.
Comment 7 Jonathan Druart 2013-04-10 12:42:24 UTC
Nicole,

This block is generated by the services/itemrecorddisplay.pl script.
If it does not appear, the script certainly spits logs.
Could you check your Koha log file please?
Comment 8 Nicole C. Engard 2013-04-10 15:18:41 UTC
I don't have a 3.8.1 system anymore to check the logs on.
Comment 9 Owen Leonard 2013-04-10 15:33:41 UTC
> I don't have a 3.8.1 system anymore to check the logs on.

You could check out 3.8.x for testing:

git checkout origin/3.8.x
Comment 10 shalomchong 2013-04-11 01:19:38 UTC
i think only verson 3.08.01.001 has this problem. my system upgrade from 3.08.01.001  to 3.10 the problem remain. but there is another user who re-install his system to 3.08.01.002 the problem solved.
Comment 11 Nicole C. Engard 2013-05-08 11:58:57 UTC
We are still seeing this in 3.10.3
Comment 12 Jonathan Druart 2013-05-13 09:56:16 UTC
I checked out 3.10.3

commit db3cf8e62017e40533164edb0ab91cabf69f1f3b
Refs: [v3.10.03], HEAD
Author:     Chris Cormack <chrisc@catalyst.net.nz>
AuthorDate: Mon Feb 25 06:36:04 2013 +1300
Commit:     Chris Cormack <chrisc@catalyst.net.nz>
CommitDate: Mon Feb 25 06:36:04 2013 +1300

and I cannot reproduce the issue.

Did you check the logs?
Comment 13 Katrin Fischer 2014-05-17 11:43:40 UTC
Nicole, can this be closed? I had this never happen to me in newer versions - so hopefully it's gone.
Comment 14 Nicole C. Engard 2014-05-31 16:34:14 UTC
Sure