Bug 8330 - Overdues email subject contains untranslatable 'Overdue:' string
Summary: Overdues email subject contains untranslatable 'Overdue:' string
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Katrin Fischer
QA Contact:
URL:
Whiteboard:
Keywords:
: 8468 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-28 12:44 UTC by Katrin Fischer
Modified: 2016-12-05 21:22 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 8330: Overdue email link contains untranslatable 'Overdue:' (3.29 KB, patch)
2015-06-07 23:01 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8330: Overdue email link contains untranslatable 'Overdue:' (3.34 KB, patch)
2015-06-10 21:03 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 8330: Overdue email link contains untranslatable 'Overdue:' (3.34 KB, patch)
2015-06-16 15:52 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2012-06-28 12:44:07 UTC
The overdue with fines report contains email links with a subject line:
Overdue: <title>

The "Overdue" is not translatable.
Comment 1 Katrin Fischer 2012-07-19 07:35:13 UTC
*** Bug 8468 has been marked as a duplicate of this bug. ***
Comment 2 Owen Leonard 2012-08-07 20:18:02 UTC
I wonder if these links are ever used? 

Would be possible to instead generate a one-time notice?
Comment 3 Katrin Fischer 2012-08-07 20:32:56 UTC
Hi Owen, 

an option so send a real mail from there using a notice template would certainly be much better!
Comment 4 Gaetan Boisson 2012-08-08 07:17:19 UTC
They are used in at least one library i know of.
I think it makes sense to have this functionnality in a report that lists overdues. Even though i agree most libraries will choose to automate sending overdue notices. Some are small enough and would rather take care of it 100% manually, other might want to be able to send another notice, manually in some cases.
Comment 5 Gaetan Boisson 2012-08-08 07:18:39 UTC
Actually there used to be, i've seen it in libraries using an older version, a 'MANUAL_ODUE' notice, which would be sent from here.
Comment 6 Katrin Fischer 2012-08-08 07:36:10 UTC
Hi Gaetan,

yes, and we have been trying to make it work in the past - see bug 4990.
Seems it was working in 2.2, then it got reintegrated in 3.0.x, while development was already done for 3.2. There never was a working patch for 3.2 (master back then), so the the feature got lost again after updating from 3.0.x.
Comment 7 Katrin Fischer 2015-06-06 22:51:22 UTC
This is still valid.

I think generating manual overdue emails could maybe be dealt with on bug 4990 and only fix the wrong string here for now.
Comment 8 Katrin Fischer 2015-06-07 23:01:03 UTC Comment hidden (obsolete)
Comment 9 Nick Clemens 2015-06-10 21:03:01 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2015-06-16 15:52:13 UTC
Created attachment 40190 [details] [review]
Bug 8330: Overdue email link contains untranslatable 'Overdue:'

The translation scripts don't pick up text from href attributes,
which is what we want, with a small exception for this script.

Patch uses a TT trick to make the Overdue: in the subject
of the mailto: link translatable.

Regression test:
- Make sure you have an overdue item
- Go to Circulation > Overdues
- Verify the [email] link works and a subject
  with 'Overdue: <title>' is generated
- Apply patch and repeat steps

Bonus: Verify the branch name now shows instead of
       the branchcode in the table

To test translatability:
- cd misc/translator
- perl translate update de-DE
- Open file po/de-DE-staff-prog.po
- Search for Overdue:
- Translate string, remove 'fuzzy' marker
- perl translate install de-DE
- Test again, subject should now be translated

Signed-off-by: Nick Clemens <nick@quecheelibrary.org>
Comment 11 Tomás Cohen Arazi 2015-06-22 14:56:31 UTC
Patch pushed to master.

Nice one Katrina!
Comment 12 Chris Cormack 2015-07-09 21:17:35 UTC
Pushed to 3.20.x will be in 3.20.2