Bug 8349 - Attempted string substitution in C4::Breeding fails on undefined
Summary: Attempted string substitution in C4::Breeding fails on undefined
Status: RESOLVED DUPLICATE of bug 8350
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic record staging/import (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-03 11:02 UTC by M. Tompsett
Modified: 2012-07-03 12:22 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Moved the substitution inside the if statement (1.13 KB, patch)
2012-07-03 11:23 UTC, M. Tompsett
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description M. Tompsett 2012-07-03 11:02:35 UTC
Encountered the bug in 3.6.3 and confirmed it in my development environment.
By moving the line, this can be compensated for. Patch to follow.
Comment 1 M. Tompsett 2012-07-03 11:23:50 UTC
Created attachment 10623 [details] [review]
Moved the substitution inside the if statement

While generating this patch, I realized that the if statement needs fixing too. Bug report to follow for that problem. However, the if statement modification won't affect the NULL case, which is being handled by moving this. It does differ technically in the case of 0 or '0', however the result is the same.
Comment 2 M. Tompsett 2012-07-03 12:22:16 UTC
Marking as duplicate, because my patch on 8350 will solve this problem and the poorly defined if issues.

*** This bug has been marked as a duplicate of bug 8350 ***