Bug 8360 - Author facet not working
Summary: Author facet not working
Status: CLOSED INVALID
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Fridolin Somers
QA Contact:
URL:
Keywords:
: 8345 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-05 12:21 UTC by Adrien SAURAT
Modified: 2014-12-07 20:02 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
proposed patch #1 (1.53 KB, patch)
2012-07-05 12:29 UTC, Adrien SAURAT
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Adrien SAURAT 2012-07-05 12:21:06 UTC
After a search on the OPAC, clicking on the Author facet gives bad results, sometimes an empty screen when several biblios should appear.

It is so in UNIMARC at least, and I'll propose a patch for this (correcting the facet construction by adding wordlist "wrdl" to the limit parameter), but if MARC21 biblios have the same problem I'll make a version with both codes modified.
Comment 1 Adrien SAURAT 2012-07-05 12:29:09 UTC Comment hidden (obsolete)
Comment 2 Frédéric Demians 2012-07-07 06:31:01 UTC
I confirm the bug. Why 'wrdl' and not 'phr'?
Comment 3 Gaetan Boisson 2012-07-10 13:06:10 UTC
*** Bug 8345 has been marked as a duplicate of this bug. ***
Comment 4 Jared Camins-Esakov 2012-07-20 18:33:40 UTC
I would agree that this should probably be ,phr. Is there a reason you chose ,wrdl, Adrien?
Comment 5 Gaetan Boisson 2012-11-12 10:44:43 UTC
I can't say what the reason was for Adrien to choose wrdl, but i just tried both on an instance where i encountered the problem, and using phr doesn't give any result, whereas wrdl does.
Comment 6 Fridolin Somers 2013-07-08 09:00:12 UTC
I think this patch is not a solution.

We know the search with "phrase" structure (witch in implicit for Zebra) sometimes does not work.

But using "word list" is wrong because it performs a search of words without order. There can be problems with some facets, for example authors "Pierre JUSTE" and "Juste PIERRE". A click on a facet "au,wrld=Pierre JUSTE" will return results with both authors.

Problems must be fixed in search engine.
Comment 7 mathieu saby 2013-09-16 07:44:26 UTC
I have a plan to improve facets. Could you please take a look and comment the bug if you have any remarks?
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10891

M. Saby
Comment 8 Fridolin Somers 2013-09-18 12:31:03 UTC
I've found the primary cause of this bug : when using GRS1, only ICU allows to search a phrase with words over several subfields.
I set invalid.