Bug 8389 - BEGIN considered harmful
Summary: BEGIN considered harmful
Status: RESOLVED DUPLICATE of bug 27246
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-09 12:22 UTC by Jared Camins-Esakov
Modified: 2020-12-16 10:12 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2012-07-09 12:22:48 UTC
Right now we are using BEGIN { } blocks in a lot of C4, including for database access in C4::Context. This means that any script that uses C4::Context, even if it doesn't actually need the database or is not being run, just compiled, will not function without a database present.
Comment 1 Jonathan Druart 2020-12-16 10:12:17 UTC
This was no longer valid.
See also related bug 27246.

*** This bug has been marked as a duplicate of bug 27246 ***