Bug 8412 - add color icon set
Summary: add color icon set
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Nicole C. Engard
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 21:15 UTC by Nicole C. Engard
Modified: 2014-12-07 20:02 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8412: add color icon set (585.73 KB, patch)
2012-07-10 21:18 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 8412: add color icon set (180.58 KB, patch)
2012-08-06 13:05 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 8412: add color icon set (180.58 KB, patch)
2012-08-06 13:07 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8412: add color icon set (181.16 KB, patch)
2012-08-09 14:58 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-07-10 21:15:18 UTC
My goal here is to make it so that libraries can use one of the authorized values (shelving location or collection code) to store the color of the material and then make that searchable on the advanced search page.

To do this for collection codes you'd need to add the following jqueries:

intranetuserjs

$(document).ready(function(){
$("#advsearch-tab-ccode a:contains('Collection')").text("Color");
$("#holdings th:contains('Collection')").text("Color");
});


opacuserjs

$(document).ready(function(){
$("#advsearch-tab-ccode a:contains('Collection')").text("Color");
$('#item_ccode').text("Color");
});


And update the frameworks to change the 952$8 label to say Color.

I'll add this tip to a blog post and to the manual once this set of icons has been pushed to Koha.

Obviously this patch just has images, no code.
Comment 1 Nicole C. Engard 2012-07-10 21:18:05 UTC Comment hidden (obsolete)
Comment 2 Ian Walls 2012-07-11 19:20:49 UTC
I can see how low impact this is in order to add the feature of search/sort by color.  But adding 146 pngs that are just basic solid colors seems... redundant to me.  Why not use CSS to take the hex code, and render a region (of adjustable size) in that color?  It would work as a MARC framework plugin, most likely, and could be connected to a color picker tool (I'm positive JQuery has one or more pre-canned).

Not trying to over complicate things, just keep Koha lean and efficient.
Comment 3 Nicole C. Engard 2012-07-11 19:54:10 UTC
Authorized values need images to go with them - we can have fewer images if you want - but I don't know a thing about how to make the system do what you want it to do cause it would require editing how images are attached to item types and other authorized values and how they show in the search results.  This seemed the easiest way and they're very very small image files.
Comment 4 Owen Leonard 2012-07-17 19:02:42 UTC
I'm not so concerned about the file size, but I do think there are too many color choices. I think a light and dark version of each color is probably enough: light green, dark green, light blue, dark blue, etc. 10 variations on "green" is probably overkill for most people.

It would probably also be helpful to offer SQL for doing a mass insert of these values into collection codes.
Comment 5 Nicole C. Engard 2012-08-06 12:38:09 UTC
My thinking was law libraries and the different shades of law books :) but here is a smaller set of images, I'd like to allow people to download the entire site of images via the wiki maybe or something if that helps. 

As for the SQL do you mean as a tip on the patch? I can totally do that, I can also add a new authorized value for Colors, but then that has to be moved to LOC or CCOODE if you plan to use one of those for holding color info.  Keep an eye out - new patch coming in a few minutes.
Comment 6 Nicole C. Engard 2012-08-06 13:05:18 UTC Comment hidden (obsolete)
Comment 7 Nicole C. Engard 2012-08-06 13:07:37 UTC Comment hidden (obsolete)
Comment 8 Julian Maurice 2012-08-09 14:58:09 UTC
Created attachment 11509 [details] [review]
[SIGNED-OFF] Bug 8412: add color icon set

Patch only adds image files in a new directory, so it's a safe change.
Number of files have been reduced and SQL snippet attached to the patch, as requested by Owen.
No reasons to not signoff.
Comment 9 Jonathan Druart 2012-08-22 09:41:47 UTC
QA Comment:

This patch adds a color icon set for opac and intranet.

Marked as Passed QA.
Comment 10 Paul Poulain 2012-09-03 15:46:10 UTC
mmm... do we really need this patch ? There is an option to provide a complete/external URL. Shouldn't your library just have their own "ccode-that-are-colors" on their own location and setup ccode accordingly ?
Comment 11 Paul Poulain 2012-09-03 15:48:03 UTC
(In reply to comment #10)
> mmm... do we really need this patch ? There is an option to provide a
> complete/external URL. Shouldn't your library just have their own
> "ccode-that-are-colors" on their own location and setup ccode accordingly ?

I just discover that the option exist for itemtypes.pl, but not for authorised_values. I don't see why (and it should probably be fixed)
Comment 12 Nicole C. Engard 2012-09-04 14:02:38 UTC
Not all libraries have a place to host their own images, or know how to host their own images, so adding these makes it easy for those types of people. And once again, it's just a few small images, it's not a big drain on the system so I'm not sure why we wouldn't add them. 

As for why it's not showing in authorized values ... does anyone know why that would happen?  I put the images where I always do.

Nicole
Comment 13 Nicole C. Engard 2012-09-04 14:59:35 UTC
Paul,

I reapplied the patch to my system and I see the colors tab when editing authorized values, so can you explain what problem you're seeing?

Nicole
Comment 14 Paul Poulain 2012-09-05 13:00:39 UTC
(In reply to comment #13)
> Paul,
> 
> I reapplied the patch to my system and I see the colors tab when editing
> authorized values, so can you explain what problem you're seeing?
The problem is just that i'm not seeing the link for an external image on authorized values, as there is one on itemtypes. It's not related to your patch at all.(In reply to comment #12)

> Not all libraries have a place to host their own images, or know how to host
> their own images, so adding these makes it easy for those types of people.
> And once again, it's just a few small images, it's not a big drain on the
> system so I'm not sure why we wouldn't add them. 
> I put the images where I always do.
Until now, images where always showing something that was understandable & useful for most libraries, so it's common interest to have them shipped with Koha. Those "image=color" are completely meaningless for me (& probably most french libraries)

Are they related to a color scheme that US libraries usually understand, or are they specific to ONE library ?
If they are specific to one library, I think we should not add them
If they are meaningfull for many (like : "most libraries use yellow for 1XX dewey, orange for 2XX, red for 3XX, ...") , I'll push the patch
Comment 15 Nicole C. Engard 2012-09-05 13:05:42 UTC
Lots of libraries report that patrons come to the desk and say do you know that book about dogs with the yellow cover (or something like that). There have been articles in library journals about cataloging colors to make this kind of searching easier. One library I have found that does this is : http://portia.nesl.edu/screens/well_its_red.html click the color and you get a search for books with that color in the cover.

This is a specialized feature, but one that many liked the idea of when I tweeted about it originally and like I said one that many libraries have expressed an interest in in general (not Koha specific libraries only).

Nicole
Comment 16 Kyle M Hall 2012-09-05 13:14:13 UTC
> Are they related to a color scheme that US libraries usually understand, or
> are they specific to ONE library ?
> If they are specific to one library, I think we should not add them
> If they are meaningfull for many (like : "most libraries use yellow for 1XX
> dewey, orange for 2XX, red for 3XX, ...") , I'll push the patch

I don't think this is only specific and useful to a single library. It seems like something that could be a feature for a large number of libraries ( e.g. law firm libraries ).

Other libraries may find uses for this feature that we haven't even thought of! Perhaps a library or two color code sections of shelving, in which case this feature would allow a library to give simple feedback on which area an item would be located in.

In the end, it doesn't affect existing functionality, and can be safely ignored by those who are not interested in it, so why take away something that might be useful?
Comment 17 Paul Poulain 2012-09-12 12:40:10 UTC
Patch pushed to master

Final comment: definitely, I'm not a big fan of this patch. I feel it could have been written another way. However, it's highly not intrusive, so easy to remove if another option for picking a color is written. So I've pushed the patch.
Comment 18 Suzanne Fayle 2013-05-20 22:36:08 UTC
This feature would be of use to us for sure. But I'd like to see more colors available.