Bug 8424 - Multiple invoices for subscriptions
Summary: Multiple invoices for subscriptions
Status: RESOLVED DUPLICATE of bug 5339
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Amit Gupta
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-12 04:16 UTC by Savitra Sirohi
Modified: 2013-04-14 08:09 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Savitra Sirohi 2012-07-12 04:16:47 UTC
In Indian libraries multiple invoices can be received for a serial subcription. This change will move storage of invoice details (price, invoice no. and date) to a new table - aqinvoices.

The table will have colums:
1) ordernumber  (FK to aqorders)
2) invoicenumber 
3) invoicedate
4) price 
5) entrydate
6) timestamp

For books, Koha currently creates a new aqorders line when a single title is received under different invoices. It might be better to store these multiple invoice nos. in this new table instead of creating new order lines.
Comment 1 Katrin Fischer 2012-07-12 04:30:13 UTC
Hi Amit and Savitra, take a look at bug 5339 - it looks like this is very similar to what you are describing here, even the table name is the same.
Comment 2 Katrin Fischer 2013-04-14 08:09:24 UTC
A table aqorders has been implemented for Koha 3.10 in bug 5339.

*** This bug has been marked as a duplicate of bug 5339 ***