Bug 8474 - Holds done by librarians cause silent errors in koha-error_log
Summary: Holds done by librarians cause silent errors in koha-error_log
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Olli-Antti Kivilahti
QA Contact:
URL:
Whiteboard:
Keywords:
: 8531 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-19 11:14 UTC by Piotr Kowalski
Modified: 2015-12-03 22:03 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Proposed patches to request.pl and placerequest.pl modules (4.75 KB, text/plain)
2012-07-19 11:14 UTC, Piotr Kowalski
Details
Bug 8474 - Holds done by librarians cause silent errors in koha-error_log, placerequest.pl -> $checkitem (1.25 KB, patch)
2014-07-23 08:17 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 8474 - Holds done by librarians cause silent errors in koha-error_log, placerequest.pl -> $checkitem (1.64 KB, patch)
2015-04-13 09:12 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 8474 - Holds done by librarians cause silent errors in koha-error_log, placerequest.pl -> $checkitem (1.73 KB, patch)
2015-04-15 21:48 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kowalski 2012-07-19 11:14:39 UTC Comment hidden (obsolete)
Comment 1 Owen Leonard 2013-08-13 16:53:57 UTC
This bug still affects master, but the patch isn't formatted correctly to even try to apply.
Comment 2 Katrin Fischer 2014-07-12 12:07:27 UTC
*** Bug 8531 has been marked as a duplicate of this bug. ***
Comment 3 Olli-Antti Kivilahti 2014-07-23 08:17:08 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-04-13 09:12:51 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2015-04-15 21:48:42 UTC
Created attachment 37932 [details] [review]
[PASSED QA] Bug 8474 - Holds done by librarians cause silent errors in koha-error_log, placerequest.pl -> $checkitem

Squashed this rogue variable initialization

Test plan:
1/ Place a hold at a biblio level (on the next available item)
2/ Without this patch you get
placerequest.pl: Use of uninitialized value $checkitem in string ne at /home/koha/src/reserve/placerequest.pl line 75.
placerequest.pl: Use of uninitialized value $checkitem in string ne at /home/koha/src/reserve/placerequest.pl line 101.

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Fixed a tab.
Comment 6 Tomás Cohen Arazi 2015-04-23 16:14:01 UTC
Patch pushed to master.

we love removing useless warnings, thanks Olli!
Comment 7 Chris Cormack 2015-05-11 22:47:54 UTC
Pushed to 3.18.x will be in 3.18.7